markdown-it: Quadratic-time denial of service in inline HTML parsing with html enabled
CVE-2026-111766GHSA-vfgh-jcmw-g37q
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (markdown-it 15.0.3, 14.3.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm markdown-it
- Affected
- < 14.3.3>= 15.0.0, < 15.0.3
- Fixed in
- 15.0.3, 14.3.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vfgh-jcmw-g37q lists affected ranges: npm markdown-it >=0 =15.0.0 <15.0.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vfgh-jcmw-g37q lists affected ranges: npm markdown-it >=0 =15.0.0 <15.0.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
- EPSS
- CVE-2026-111766: 0.43% estimated exploitation activity in the next 30 days; percentile 37.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary With html: true, markdown-it takes quadratic time to parse repeated unterminated HTML constructs inside a paragraph. This affects HTML comments (<!--), processing instructions (<?), declarations (<!A), and CDATA sections (<!CDATA[). An attacker-controlled input of a few hundred kilobytes can block the Node.js event loop for seconds or tens of seconds. The default configuration has HTML disabled, but the commonmark preset enables it. The issue was reported against the published markdown-it@15.0.2 package on Node.js 20 and reproduced on the current source with Node.js 24.16.0. Details src/rulesinline/text.ts treats < as a terminator, causing the inline parser to attempt the HTML rule at successive HTML construct openers. With HTML enabled, src/rulesinline/htmlinline.ts applies an anchored regular expression to the remaining input: The comment, processing instruction, declaration, and CDATA alternatives in src/common/htmlre.ts scan the remaining input for their respective…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-vfgh-jcmw-g37q
- Revision 2 · amended ·
Amended from osv record GHSA-vfgh-jcmw-g37q
- Revision 1 · created ·
Published from ghsa record GHSA-vfgh-jcmw-g37q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-111766 Advisory: markdown-it: Quadratic-time denial of service in inline HTML parsing with html enabled IDs: CVE-2026-111766, GHSA-vfgh-jcmw-g37q Record: https://patchnext.com/advisories/cve-2026-111766 (revision 3, source checked 26 Oct 2026, 13:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: markdown-it 15.0.3, 14.3.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm markdown-it: affected < 14.3.3; >= 15.0.0, < 15.0.3; fixed in 15.0.3, 14.3.3 ## Suggested inspection (read-only) - `npm ls markdown-it --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on markdown-it. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vfgh-jcmw-g37q (GitHub-reviewed advisory GHSA-vfgh-jcmw-g37q lists affected ranges: npm markdown-it >=0 =15.0.0 <15.0.3) - Verified: https://osv.dev/vulnerability/GHSA-vfgh-jcmw-g37q (OSV record GHSA-vfgh-jcmw-g37q lists affected ranges: npm markdown-it >=0 =15.0.0 <15.0.3 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…