Skip to content

← Actionable
High, CVSS 7.5amended

markdown-it: Quadratic complexity in smartquotes with unmatched closing quotes

CVE-2026-111759GHSA-r7fv-28h4-cvq7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (markdown-it 15.0.2, 14.3.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm markdown-it

    Affected
    >= 15.0.0, < 15.0.2< 14.3.2
    Fixed in
    15.0.2, 14.3.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-111759: 0.59% estimated exploitation activity in the next 30 days; percentile 48.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact When typographer: true is enabled, specially crafted Markdown can cause quadratic processing time in the smartquotes rule, potentially leading to denial of service in applications processing untrusted input. Many opening double quotes followed by unmatched closing single quotes cause repeated scans of the entire opener stack. The same issue occurs with the quote types reversed. The default configuration (typographer: false) is not affected, but this option is enabled with high probability. Reproduction Result: |input size|time| |-|-| |12000|18ms| |24000|47ms| |48000|115ms| |96000|428ms| |192000|1586ms| Patches Fixed in 15.0.2 and 14.3.2. Workarounds Disable typography with typographer: false, or disable only the smartquotes rule:

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-r7fv-28h4-cvq7

  2. Revision 2 · amended ·

    Amended from osv record GHSA-r7fv-28h4-cvq7

  3. Revision 1 · created ·

    Published from ghsa record GHSA-r7fv-28h4-cvq7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-111759

Advisory: markdown-it: Quadratic complexity in smartquotes with unmatched closing quotes
IDs: CVE-2026-111759, GHSA-r7fv-28h4-cvq7
Record: https://patchnext.com/advisories/cve-2026-111759 (revision 3, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: markdown-it 15.0.2, 14.3.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm markdown-it: affected >= 15.0.0, < 15.0.2; < 14.3.2; fixed in 15.0.2, 14.3.2

## Suggested inspection (read-only)
- `npm ls markdown-it --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on markdown-it.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-r7fv-28h4-cvq7 (GitHub-reviewed advisory GHSA-r7fv-28h4-cvq7 lists affected ranges: npm markdown-it >=15.0.0 =0 <14.3.2)
- Verified: https://osv.dev/vulnerability/GHSA-r7fv-28h4-cvq7 (OSV record GHSA-r7fv-28h4-cvq7 lists affected ranges: npm markdown-it >=15.0.0 =0 <14.3.2 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…