Skip to content

← Actionable
High, CVSS 8.2amended

follow-redirects array-form headers bypass cross-origin credential stripping

CVE-2026-111756GHSA-q3jh-wrc6-jgq8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (follow-redirects 1.16.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-111756: 0.47% estimated exploitation activity in the next 30 days; percentile 40.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary follow-redirects removes sensitive credential headers (Authorization, Proxy-Authorization, Cookie, and any caller-declared sensitiveHeaders) before following a redirect that crosses to a different host or downgrades to a less secure protocol. The removal routine iterates the caller's headers container with for...in and matches header names against a filter. This assumes the headers container is a plain object keyed by header names. Node's underlying http.request, which follow-redirects is a drop-in replacement for, also accepts headers as an alternating array of names and values. For an array, for...in yields the numeric indices "0", "1", "2" and so on, which never match a header-name filter, so nothing is removed. An application that sends array-form headers and follows an attacker-controlled cross-origin redirect therefore forwards its Authorization, Cookie, and Proxy-Authorization headers verbatim to the attacker-controlled destination, with no error or warning. The…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-q3jh-wrc6-jgq8

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-q3jh-wrc6-jgq8

  4. Revision 1 · created ·

    Published from ghsa record GHSA-q3jh-wrc6-jgq8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-111756

Advisory: follow-redirects array-form headers bypass cross-origin credential stripping
IDs: CVE-2026-111756, GHSA-q3jh-wrc6-jgq8
Record: https://patchnext.com/advisories/cve-2026-111756 (revision 4, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: follow-redirects 1.16.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm follow-redirects: affected >= 1.16.0, < 1.16.1; fixed in 1.16.1

## Suggested inspection (read-only)
- `npm ls follow-redirects --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on follow-redirects.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-q3jh-wrc6-jgq8 (GitHub-reviewed advisory GHSA-q3jh-wrc6-jgq8 lists affected ranges: npm follow-redirects >=1.16.0 <1.16.1)
- Verified: https://osv.dev/vulnerability/GHSA-q3jh-wrc6-jgq8 (OSV record GHSA-q3jh-wrc6-jgq8 lists affected ranges: npm follow-redirects >=1.16.0 <1.16.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…