Lollms has an Improper Access Control vulnerability
CVE-2026-1117GHSA-82fw-ch24-j34w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (lollms 2.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI lollms
- Affected
- < 2.1.0
- Fixed in
- 2.1.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-82fw-ch24-j34w lists affected ranges: PyPI lollms >=0 <2.1.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-82fw-ch24-j34w lists affected ranges: PyPI lollms >=0 <2.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.2 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H
- EPSS
- CVE-2026-1117: 0.58% estimated exploitation activity in the next 30 days; percentile 48.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability in the lollmsgenerationevents.py component of parisneo/lollms version 5.9.0 allows unauthenticated access to sensitive Socket.IO events. The addevents function registers event handlers such as generatetext, cancelgeneration, generatemsg, and generatemsgfrom without implementing authentication or authorization checks. This allows unauthenticated clients to execute resource-intensive or state-altering operations, leading to potential denial of service, state corruption, and race conditions. Additionally, the use of global flags (lollmsElfServer.busy, lollmsElfServer.cancelgen) for state management in a multi-client environment introduces further vulnerabilities, enabling one client's actions to affect the server's state and other clients' operations. The lack of proper access control and reliance on insecure global state management significantly impacts the availability and integrity of the service.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-82fw-ch24-j34w
- Revision 1 · created ·
Published from osv record GHSA-82fw-ch24-j34w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-1117 Advisory: Lollms has an Improper Access Control vulnerability IDs: CVE-2026-1117, GHSA-82fw-ch24-j34w Record: https://patchnext.com/advisories/cve-2026-1117 (revision 2, source checked 26 Oct 2026, 13:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: lollms 2.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI lollms: affected < 2.1.0; fixed in 2.1.0 ## Suggested inspection (read-only) - `python -m pip show lollms`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on lollms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-82fw-ch24-j34w (OSV record GHSA-82fw-ch24-j34w lists affected ranges: PyPI lollms >=0 <2.1.0 (fixed)) - Verified: https://github.com/advisories/GHSA-82fw-ch24-j34w (GitHub-reviewed advisory GHSA-82fw-ch24-j34w lists affected ranges: PyPI lollms >=0 <2.1.0) Commands are suggestions: review each one before running it.
Loading voting…