body-parser vulnerable to Denial of Service via trailing bytes after a compressed request body
CVE-2026-111181GHSA-27r3-jxmh-p828
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (body-parser 2.4.0, 1.20.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm body-parser
- Affected
- >= 2.0.0, < 2.4.0< 1.20.9
- Fixed in
- 2.4.0, 1.20.9
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-27r3-jxmh-p828 lists affected ranges: npm body-parser >=2.0.0 =0 <1.20.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-27r3-jxmh-p828 lists affected ranges: npm body-parser >=2.0.0 =0 <1.20.9 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-111181: 0.39% estimated exploitation activity in the next 30 days; percentile 32.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A single request can crash any application using body-parser with default options. When a request carries a Content-Encoding (for example gzip), body-parser pipes it into a decompression stream and, after reading the body, leaves that stream piped with no error listener. A payload of one valid compressed frame followed by trailing bytes decodes and the application responds normally, but the trailing bytes then reach the already-finished decoder, which emits an error that is re-thrown as an uncaught exception and terminates the process. No authentication or matching route is required, since parsing runs before routing. Patches Fixed in body-parser 2.4.0 and 1.20.9. Upgrade to one of these versions. Workarounds Pass inflate: false to the body-parser middleware if the application does not need to accept compressed request bodies. This rejects encoded requests before any decompression stream is created.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-27r3-jxmh-p828
- Revision 2 · amended ·
Amended from osv record GHSA-27r3-jxmh-p828
- Revision 1 · created ·
Published from ghsa record GHSA-27r3-jxmh-p828
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-111181 Advisory: body-parser vulnerable to Denial of Service via trailing bytes after a compressed request body IDs: CVE-2026-111181, GHSA-27r3-jxmh-p828 Record: https://patchnext.com/advisories/cve-2026-111181 (revision 3, source checked 26 Oct 2026, 13:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: body-parser 2.4.0, 1.20.9. A vendor fix does not mean a deployment is fixed. ## Affected components - npm body-parser: affected >= 2.0.0, < 2.4.0; < 1.20.9; fixed in 2.4.0, 1.20.9 ## Suggested inspection (read-only) - `npm ls body-parser --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on body-parser. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-27r3-jxmh-p828 (GitHub-reviewed advisory GHSA-27r3-jxmh-p828 lists affected ranges: npm body-parser >=2.0.0 =0 <1.20.9) - Verified: https://osv.dev/vulnerability/GHSA-27r3-jxmh-p828 (OSV record GHSA-27r3-jxmh-p828 lists affected ranges: npm body-parser >=2.0.0 =0 <1.20.9 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…