Skip to content

← Actionable
Medium, CVSS 6.5amended

kedro-datasets has a path traversal vulnerability in PartitionedDataset that allows arbitrary file write

CVE-2026-111170GHSA-cjg8-h5qc-hrjv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (kedro-datasets 9.3.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2026-111170: 0.39% estimated exploitation activity in the next 30 days; percentile 33.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
  • CVE-2026-35492: 0.43% estimated exploitation activity in the next 30 days; percentile 37.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact PartitionedDataset in kedro-datasets was vulnerable to path traversal. Partition IDs were concatenated directly with the dataset base path without validation. An attacker or malicious input containing .. components in a partition ID could cause files to be written outside the configured dataset directory, potentially overwriting arbitrary files on the filesystem. Users of PartitionedDataset with any storage backend (local filesystem, S3, GCS, etc.) are affected. Patches Yes. The vulnerability has been patched in kedro-datasets version 9.3.0. Users should upgrade to kedro-datasets = 9.3.0. The fix normalizes constructed paths using posixpath.normpath and validates that the resolved path remains within the dataset base directory before use, raising a DatasetError if the path escapes the base directory. Workarounds Users who cannot upgrade should validate partition IDs before passing them to PartitionedDataset, ensuring they do not contain .. path components. References Fix:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-cjg8-h5qc-hrjv

  2. Revision 1 · created ·

    Published from osv record GHSA-cjg8-h5qc-hrjv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-111170

Advisory: kedro-datasets has a path traversal vulnerability in PartitionedDataset that allows arbitrary file write
IDs: CVE-2026-111170, GHSA-cjg8-h5qc-hrjv
Record: https://patchnext.com/advisories/cve-2026-111170 (revision 2, source checked 26 Oct 2026, 13:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: kedro-datasets 9.3.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI kedro-datasets: affected < 9.3.0; fixed in 9.3.0

## Suggested inspection (read-only)
- `python -m pip show kedro-datasets`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on kedro-datasets.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-cjg8-h5qc-hrjv (OSV record GHSA-cjg8-h5qc-hrjv lists affected ranges: PyPI kedro-datasets >=0 <9.3.0 (fixed))
- Verified: https://github.com/advisories/GHSA-cjg8-h5qc-hrjv (GitHub-reviewed advisory GHSA-cjg8-h5qc-hrjv lists affected ranges: PyPI kedro-datasets >=0 <9.3.0)

Commands are suggestions: review each one before running it.

Loading voting…