Skip to content

← Actionable
Medium, CVSS 6.3amended

AIOHTTP: Secure attribute not enforced for shared cookie

CVE-2026-111063GHSA-494j-54xm-rwp3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (aiohttp 3.14.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI aiohttp

    Affected
    < 3.14.4
    Fixed in
    3.14.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-111063: 0.23% estimated exploitation activity in the next 30 days; percentile 14.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The Secure attribute was not being enforced for the shared cookie.

Impact It may be possible to send a shared cookie marked Secure through an unencrypted request.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 5 · amended ·

    Amended from osv record GHSA-494j-54xm-rwp3

  2. Revision 4 · amended ·

    Amended from ghsa record GHSA-494j-54xm-rwp3

  3. Revision 3 · amended ·

    Amended from ghsa record GHSA-494j-54xm-rwp3

  4. Revision 2 · amended ·

    Amended from osv record GHSA-494j-54xm-rwp3

  5. Revision 1 · created ·

    Published from ghsa record GHSA-494j-54xm-rwp3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-111063

Advisory: AIOHTTP: Secure attribute not enforced for shared cookie
IDs: CVE-2026-111063, GHSA-494j-54xm-rwp3
Record: https://patchnext.com/advisories/cve-2026-111063 (revision 5, source checked 27 Oct 2026, 06:15 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: aiohttp 3.14.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI aiohttp: affected < 3.14.4; fixed in 3.14.4

## Suggested inspection (read-only)
- `python -m pip show aiohttp`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on aiohttp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-494j-54xm-rwp3 (GitHub-reviewed advisory GHSA-494j-54xm-rwp3 lists affected ranges: PyPI aiohttp >=0 <=3.14.3)
- Verified: https://osv.dev/vulnerability/GHSA-494j-54xm-rwp3 (OSV record GHSA-494j-54xm-rwp3 lists affected ranges: PyPI aiohttp >=0 <3.14.4 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…