Skip to content

← Actionable
Medium, CVSS 6.5amended

Nodemailer: Quadratic (O(n^2)) DKIM header unfolding lets a large folded header cause remote denial of service during signing

CVE-2026-110871GHSA-39m8-27wv-hr27

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nodemailer 10.0.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm nodemailer

    Affected
    >= 3.0.0, <= 10.0.9
    Fixed in
    10.0.10

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-110871: 0.38% estimated exploitation activity in the next 30 days; percentile 32.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary When nodemailer DKIM-signs an outbound message, its DKIM message parser unfolds RFC 5322 header continuation lines with a loop that concatenates each continuation line onto the preceding line and then re-tests the anchored regex /^[ \t]/ against the growing merged line on every iteration. Re-testing the regex against the ever-growing accumulated line forces a full string flatten proportional to the accumulated length on each iteration, yielding O(n^2) CPU in the number of continuation lines. An application user who influences the size of a header that folds into many continuation lines (most naturally a large recipient list, but also a long custom header, Subject, or References) can drive tens of thousands of continuation lines and block the single-threaded Node.js event loop for seconds during signing, a repeatable denial of service. Root Cause The invariant that signing a message performs work linear in the message size is violated in the header-unfolding step. In…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-39m8-27wv-hr27

  2. Revision 2 · amended ·

    Amended from osv record GHSA-39m8-27wv-hr27

  3. Revision 1 · created ·

    Published from ghsa record GHSA-39m8-27wv-hr27

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-110871

Advisory: Nodemailer: Quadratic (O(n^2)) DKIM header unfolding lets a large folded header cause remote denial of service during signing
IDs: CVE-2026-110871, GHSA-39m8-27wv-hr27
Record: https://patchnext.com/advisories/cve-2026-110871 (revision 3, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nodemailer 10.0.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm nodemailer: affected >= 3.0.0, <= 10.0.9; fixed in 10.0.10

## Suggested inspection (read-only)
- `npm ls nodemailer --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nodemailer.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-39m8-27wv-hr27 (GitHub-reviewed advisory GHSA-39m8-27wv-hr27 lists affected ranges: npm nodemailer >=3.0.0 <=10.0.9)
- Verified: https://osv.dev/vulnerability/GHSA-39m8-27wv-hr27 (OSV record GHSA-39m8-27wv-hr27 lists affected ranges: npm nodemailer >=3.0.0 <10.0.10 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…