Skip to content

← Actionable
Low, CVSS 3.7amended

fast-uri vulnerable to scheme injection via an unescaped first-segment colon in suffix references

CVE-2026-110725GHSA-333x-w4r6-6crp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (fast-uri 4.2.3, 3.1.9, 2.4.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm fast-uri

    Affected
    < 2.4.8>= 3.0.0, < 3.1.9>= 4.0.0, < 4.2.3
    Fixed in
    2.4.8, 4.2.3, 3.1.9

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N
EPSS
  • CVE-2026-110725: 0.30% estimated exploitation activity in the next 30 days; percentile 23.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact fast-uri's serialize(), normalize(), and resolve(), when called with the non-default option reference: 'suffix' on a reference that has no authority, emit a relative reference whose first path segment contains a bare colon without escaping it. RFC 3986 section 3.3 requires the first segment of a path-noscheme reference not to contain a colon, precisely because a bare colon makes the string reparse as an absolute URI with a scheme. fast-uri's default serialization escapes that colon, but the suffix path does not. For example, normalize('javascript:alert(1)', { reference: 'suffix' }) returns javascript:alert(1), which reparses as a live javascript: scheme; data: and vbscript: behave the same. Applications that serialize or normalize a relative reference with reference: 'suffix' and then treat the result as a URI can turn inert input into a live javascript:, data:, or vbscript: URL (a cross-site scripting vector), and equal() can conflate a scheme-bearing reference with a…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-333x-w4r6-6crp

  2. Revision 2 · amended ·

    Amended from osv record GHSA-333x-w4r6-6crp

  3. Revision 1 · created ·

    Published from ghsa record GHSA-333x-w4r6-6crp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-110725

Advisory: fast-uri vulnerable to scheme injection via an unescaped first-segment colon in suffix references
IDs: CVE-2026-110725, GHSA-333x-w4r6-6crp
Record: https://patchnext.com/advisories/cve-2026-110725 (revision 3, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: fast-uri 4.2.3, 3.1.9, 2.4.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm fast-uri: affected < 2.4.8; >= 3.0.0, < 3.1.9; >= 4.0.0, < 4.2.3; fixed in 2.4.8, 4.2.3, 3.1.9

## Suggested inspection (read-only)
- `npm ls fast-uri --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on fast-uri.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-333x-w4r6-6crp (GitHub-reviewed advisory GHSA-333x-w4r6-6crp lists affected ranges: npm fast-uri >=0 =3.0.0 =4.0.0 <4.2.3)
- Verified: https://osv.dev/vulnerability/GHSA-333x-w4r6-6crp (OSV record GHSA-333x-w4r6-6crp lists affected ranges: npm fast-uri >=0 =3.0.0 =4.0.0 <4.2.3 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…