Skip to content

← Actionable
Critical, CVSS 9.3amended

git-diff: OS command injection vulnerability via crafted strings to the gitDiff API

CVE-2026-110634GHSA-6wfj-92cw-88vg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (git-diff 2.0.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm git-diff

    Affected
    < 2.0.7
    Fixed in
    2.0.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-110634: 2.35% estimated exploitation activity in the next 30 days; percentile 83.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

git-diff before 2.0.7 contains an OS command injection vulnerability that allows attackers to execute shell commands by supplying crafted strings to the gitDiff API. Attackers who control a diffed document string can embed $(cmd) or backtick substitutions that shelljs.exec evaluates, running commands with Node.js process privileges.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-6wfj-92cw-88vg

  2. Revision 1 · created ·

    Published from ghsa record GHSA-6wfj-92cw-88vg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-110634

Advisory: git-diff: OS command injection vulnerability via crafted strings to the gitDiff API
IDs: CVE-2026-110634, GHSA-6wfj-92cw-88vg
Record: https://patchnext.com/advisories/cve-2026-110634 (revision 2, source checked 28 Oct 2026, 06:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: git-diff 2.0.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm git-diff: affected < 2.0.7; fixed in 2.0.7

## Suggested inspection (read-only)
- `npm ls git-diff --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on git-diff.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6wfj-92cw-88vg (GitHub-reviewed advisory GHSA-6wfj-92cw-88vg lists affected ranges: npm git-diff >=0 <2.0.7)
- Verified: https://osv.dev/vulnerability/GHSA-6wfj-92cw-88vg (OSV record GHSA-6wfj-92cw-88vg lists affected ranges: npm git-diff >=0 <2.0.7 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…