fast-uri vulnerable to URI scheme spoofing via percent-encoded scheme decoding
CVE-2026-110306GHSA-w74x-v6f9-j3xg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (fast-uri 4.2.3, 3.1.9, 2.4.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm fast-uri
- Affected
- < 2.4.8>= 3.0.0, < 3.1.9>= 4.0.0, < 4.2.3
- Fixed in
- 2.4.8, 4.2.3, 3.1.9
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w74x-v6f9-j3xg lists affected ranges: npm fast-uri >=0 =3.0.0 =4.0.0 <4.2.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-w74x-v6f9-j3xg lists affected ranges: npm fast-uri >=0 =3.0.0 =4.0.0 <4.2.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2026-110306: 0.25% estimated exploitation activity in the next 30 days; percentile 16.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact fast-uri percent-decodes the scheme component with the legacy global unescape() before validating it, so an input whose decoded scheme is a valid but dangerous token is emitted as a live scheme. RFC 3986 section 3.1 does not allow percent-encoding in a scheme, so no RFC or WHATWG parser treats such input as having that scheme, but fast-uri does. For example, normalize('%6Aavascript:alert(1)') returns javascript:alert(1), resolve('https://a.example/', '%6Aavascript:alert(1)') returns javascript:alert(1), and parse('%6Aavascript:alert(1)').scheme returns javascript. The %uXXXX form (%u006Aavascript:) produces the same result, and equal('%68ttp://a/', 'http://a/') returns true. An application that screens dangerous schemes on the raw input and then stores or renders normalize(input) or resolve(base, input) turns an inert string into an executable javascript:, data:, or vbscript: URL, a stored or reflected cross-site scripting vector in the consuming application. equal() also…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-w74x-v6f9-j3xg
- Revision 2 · amended ·
Amended from osv record GHSA-w74x-v6f9-j3xg
- Revision 1 · created ·
Published from ghsa record GHSA-w74x-v6f9-j3xg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-110306 Advisory: fast-uri vulnerable to URI scheme spoofing via percent-encoded scheme decoding IDs: CVE-2026-110306, GHSA-w74x-v6f9-j3xg Record: https://patchnext.com/advisories/cve-2026-110306 (revision 3, source checked 26 Oct 2026, 13:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: fast-uri 4.2.3, 3.1.9, 2.4.8. A vendor fix does not mean a deployment is fixed. ## Affected components - npm fast-uri: affected < 2.4.8; >= 3.0.0, < 3.1.9; >= 4.0.0, < 4.2.3; fixed in 2.4.8, 4.2.3, 3.1.9 ## Suggested inspection (read-only) - `npm ls fast-uri --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on fast-uri. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-w74x-v6f9-j3xg (GitHub-reviewed advisory GHSA-w74x-v6f9-j3xg lists affected ranges: npm fast-uri >=0 =3.0.0 =4.0.0 <4.2.3) - Verified: https://osv.dev/vulnerability/GHSA-w74x-v6f9-j3xg (OSV record GHSA-w74x-v6f9-j3xg lists affected ranges: npm fast-uri >=0 =3.0.0 =4.0.0 <4.2.3 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…