fast-uri vulnerable to host confusion via unchecked WHATWG host canonicalization
CVE-2026-110180GHSA-wjr9-j795-jxcr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (fast-uri 4.2.3, 3.1.9, 2.4.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm fast-uri
- Affected
- >= 2.4.2, < 2.4.8>= 3.1.3, < 3.1.9>= 4.0.1, < 4.2.3
- Fixed in
- 2.4.8, 4.2.3, 3.1.9
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wjr9-j795-jxcr lists affected ranges: npm fast-uri >=2.4.2 =3.1.3 =4.0.1 <4.2.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-wjr9-j795-jxcr lists affected ranges: npm fast-uri >=2.4.2 =3.1.3 =4.0.1 <4.2.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
- EPSS
- CVE-2026-110180: 0.26% estimated exploitation activity in the next 30 days; percentile 17.15 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact fast-uri versions = 2.4.2, <= 2.4.7, = 3.1.3, <= 3.1.8, and = 4.0.1, <= 4.2.2 can silently rewrite the host of an HTTP-family URL (http, https, ws, wss, or any scheme with domainHost: true). For those schemes canonicalizeHost() passes the parsed host to the WHATWG URL parser and adopts its .hostname without checking that the parser read the whole input as a host. RFC 3986 permits @ inside the host group and the WHATWG parser strips TAB, LF, and CR, so the authority fast-uri reports is rewritten by that second parser with no error set: data before an @ is dropped and whitespace is removed. For example, fast-uri parses http://a@b@evil.example/ to host evil.example (dropping the b segment), and a host containing a raw TAB, CR, or LF has those characters stripped. equal() then treats a whitespace-smuggled host as the same as the clean one, and resolve() rewrites the authority the same way. Applications that use fast-uri to enforce host-based policy (denylists, loopback filtering,…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-wjr9-j795-jxcr
- Revision 2 · amended ·
Amended from osv record GHSA-wjr9-j795-jxcr
- Revision 1 · created ·
Published from ghsa record GHSA-wjr9-j795-jxcr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-110180 Advisory: fast-uri vulnerable to host confusion via unchecked WHATWG host canonicalization IDs: CVE-2026-110180, GHSA-wjr9-j795-jxcr Record: https://patchnext.com/advisories/cve-2026-110180 (revision 3, source checked 26 Oct 2026, 13:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: fast-uri 4.2.3, 3.1.9, 2.4.8. A vendor fix does not mean a deployment is fixed. ## Affected components - npm fast-uri: affected >= 2.4.2, < 2.4.8; >= 3.1.3, < 3.1.9; >= 4.0.1, < 4.2.3; fixed in 2.4.8, 4.2.3, 3.1.9 ## Suggested inspection (read-only) - `npm ls fast-uri --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on fast-uri. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-wjr9-j795-jxcr (GitHub-reviewed advisory GHSA-wjr9-j795-jxcr lists affected ranges: npm fast-uri >=2.4.2 =3.1.3 =4.0.1 <4.2.3) - Verified: https://osv.dev/vulnerability/GHSA-wjr9-j795-jxcr (OSV record GHSA-wjr9-j795-jxcr lists affected ranges: npm fast-uri >=2.4.2 =3.1.3 =4.0.1 <4.2.3 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…