Skip to content

← Actionable
Low, CVSS 3.7amended

fast-uri vulnerable to improper path equivalence in relative reference normalization

CVE-2026-110095GHSA-xhq7-xmqj-769h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (fast-uri 4.2.3, 3.1.9, 2.4.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm fast-uri

    Affected
    < 2.4.8>= 3.0.0, < 3.1.9>= 4.0.0, < 4.2.3
    Fixed in
    2.4.8, 4.2.3, 3.1.9

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N
EPSS
  • CVE-2026-110095: 0.29% estimated exploitation activity in the next 30 days; percentile 21.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact fast-uri's normalize() and serialize() apply RFC 3986 dot-segment removal (removedotsegments) to the path of a relative-path reference. RFC 3986 section 5.2.4 defines that algorithm only for the merged target path during resolution, not for the reference itself, so applied to the reference it drops leading .. segments and can turn a document-relative reference into a root-relative one. For example, normalize('a/../b') returns /b and normalize('../x') returns x, so resolve(base, normalize(ref)) points at a different resource than resolve(base, ref), and equal() treats distinct references as the same. Applications that normalize attacker-supplied or user-supplied relative references and then resolve them, or use them as cache, deduplication, or authorization keys, can have a reference escape its intended directory and point at a different resource. Patches Upgrade to fast-uri 2.4.8, 3.1.9, or 4.2.3. Workarounds Do not normalize a relative reference before resolving it. Resolve…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-xhq7-xmqj-769h

  2. Revision 2 · amended ·

    Amended from osv record GHSA-xhq7-xmqj-769h

  3. Revision 1 · created ·

    Published from ghsa record GHSA-xhq7-xmqj-769h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-110095

Advisory: fast-uri vulnerable to improper path equivalence in relative reference normalization
IDs: CVE-2026-110095, GHSA-xhq7-xmqj-769h
Record: https://patchnext.com/advisories/cve-2026-110095 (revision 3, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: fast-uri 4.2.3, 3.1.9, 2.4.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm fast-uri: affected < 2.4.8; >= 3.0.0, < 3.1.9; >= 4.0.0, < 4.2.3; fixed in 2.4.8, 4.2.3, 3.1.9

## Suggested inspection (read-only)
- `npm ls fast-uri --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on fast-uri.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-xhq7-xmqj-769h (GitHub-reviewed advisory GHSA-xhq7-xmqj-769h lists affected ranges: npm fast-uri >=0 =3.0.0 =4.0.0 <4.2.3)
- Verified: https://osv.dev/vulnerability/GHSA-xhq7-xmqj-769h (OSV record GHSA-xhq7-xmqj-769h lists affected ranges: npm fast-uri >=0 =3.0.0 =4.0.0 <4.2.3 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…