undici WebSocket client vulnerable to Denial of Service via unbounded automatic PONG buffering
CVE-2026-109932GHSA-9fm3-97px-rjf6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (undici 8.12.2, 7.30.1, 6.29.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm undici
- Affected
- >= 5.15.0, < 6.29.1>= 7.0.0, < 7.30.1>= 8.0.0, < 8.12.2
- Fixed in
- 8.12.2, 6.29.1, 7.30.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9fm3-97px-rjf6 lists affected ranges: npm undici >=5.15.0 =7.0.0 =8.0.0 <8.12.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9fm3-97px-rjf6 lists affected ranges: npm undici >=5.15.0 =7.0.0 =8.0.0 <8.12.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-109932: 0.32% estimated exploitation activity in the next 30 days; percentile 25.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact undici's WebSocket client (including Node.js's bundled `globalThis.WebSocket`) can be driven to exhaust process memory by a malicious or compromised WebSocket server. For every PING frame received, the receiver automatically writes a PONG response to the socket and ignores the `false` return value from `socket.write()`, which is a backpressure signal, so a server that streams small PING frames while never reading the client's PONGs makes the outbound write queue and heap grow without bound until the Node.js process runs out of memory and terminates. The attack is remote and unauthenticated, needs only a normal WebSocket connection, and is asymmetric: small inbound PINGs produce a much larger retained outbound queue. Availability is the only impact. undici 5.x, 6.x, 7.x, and 8.x are affected; the WebSocket client was introduced in 5.15.0.
Patches Upgrade to `6.29.1`, `7.30.1`, or `8.12.2`, which pause WebSocket frame parsing when the automatic PONG response hits socket…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from osv record GHSA-9fm3-97px-rjf6
- Revision 1 · created ·
Published from ghsa record GHSA-9fm3-97px-rjf6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-109932 Advisory: undici WebSocket client vulnerable to Denial of Service via unbounded automatic PONG buffering IDs: CVE-2026-109932, GHSA-9fm3-97px-rjf6 Record: https://patchnext.com/advisories/cve-2026-109932 (revision 2, source checked 28 Oct 2026, 06:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: undici 8.12.2, 7.30.1, 6.29.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm undici: affected >= 5.15.0, < 6.29.1; >= 7.0.0, < 7.30.1; >= 8.0.0, < 8.12.2; fixed in 8.12.2, 6.29.1, 7.30.1 ## Suggested inspection (read-only) - `npm ls undici --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on undici. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9fm3-97px-rjf6 (GitHub-reviewed advisory GHSA-9fm3-97px-rjf6 lists affected ranges: npm undici >=5.15.0 =7.0.0 =8.0.0 <8.12.2) - Verified: https://osv.dev/vulnerability/GHSA-9fm3-97px-rjf6 (OSV record GHSA-9fm3-97px-rjf6 lists affected ranges: npm undici >=5.15.0 =7.0.0 =8.0.0 <8.12.2 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…