undici vulnerable to Denial of Service via unbounded memory in the EventSource parser
CVE-2026-109924GHSA-4qv8-2p9j-2685
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (undici 8.12.2, 7.30.1, 6.29.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm undici
- Affected
- >= 6.5.0, < 6.29.1>= 7.0.0, < 7.30.1>= 8.0.0, < 8.12.2
- Fixed in
- 8.12.2, 6.29.1, 7.30.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4qv8-2p9j-2685 lists affected ranges: npm undici >=6.5.0 =7.0.0 =8.0.0 <8.12.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4qv8-2p9j-2685 lists affected ranges: npm undici >=6.5.0 =7.0.0 =8.0.0 <8.12.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-109924: 0.32% estimated exploitation activity in the next 30 days; percentile 25.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact undici's EventSource client can be driven to exhaust process memory by a malicious or compromised Server-Sent Events peer. By sending millions of tiny completed data: fields with no blank event separator, or a single unfinished line split across many chunks, the parser retains a growing amount of per-field and per-chunk state. The byte-based maxEventSize and maxResponseSize limits do not bound that retained state, and maxResponseSize is enforced on the compressed body before decompression, so a small compressed response can expand into enough retained memory to terminate the process. The application only needs to maintain an EventSource connection to an untrusted peer, which controls only the response. Availability is the only impact. Patches Upgrade to 6.29.1, 7.30.1, or 8.12.2, which bound the retained EventSource parser state (the number of data fields and buffered chunks, the unfinished-line length, and per-field byte totals) independently of the byte limits. Workarounds…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-4qv8-2p9j-2685
- Revision 2 · amended ·
Amended from osv record GHSA-4qv8-2p9j-2685
- Revision 1 · created ·
Published from ghsa record GHSA-4qv8-2p9j-2685
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-109924 Advisory: undici vulnerable to Denial of Service via unbounded memory in the EventSource parser IDs: CVE-2026-109924, GHSA-4qv8-2p9j-2685 Record: https://patchnext.com/advisories/cve-2026-109924 (revision 3, source checked 26 Oct 2026, 13:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: undici 8.12.2, 7.30.1, 6.29.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm undici: affected >= 6.5.0, < 6.29.1; >= 7.0.0, < 7.30.1; >= 8.0.0, < 8.12.2; fixed in 8.12.2, 6.29.1, 7.30.1 ## Suggested inspection (read-only) - `npm ls undici --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on undici. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4qv8-2p9j-2685 (GitHub-reviewed advisory GHSA-4qv8-2p9j-2685 lists affected ranges: npm undici >=6.5.0 =7.0.0 =8.0.0 <8.12.2) - Verified: https://osv.dev/vulnerability/GHSA-4qv8-2p9j-2685 (OSV record GHSA-4qv8-2p9j-2685 lists affected ranges: npm undici >=6.5.0 =7.0.0 =8.0.0 <8.12.2 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…