Skip to content

← Actionable
High, CVSS 7.5amended

undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake

CVE-2026-109855GHSA-qq8j-7v2v-3rwp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (undici 8.11.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm undici

    Affected
    >= 8.11.0, < 8.11.2
    Fixed in
    8.11.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-109855: 0.28% estimated exploitation activity in the next 30 days; percentile 20.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact undici's experimental WebSocket client (enabled by default via `allowH2: true`) crashes the Node.js process when it connects to a malicious server over HTTP/2. If the server answers the WebSocket upgrade with a response that fails handshake validation, undici aborts the request, but the abort is a no-op because the request is already marked completed, so the underlying `ClientHttp2Stream` is left open with no error listener. When the server then destroys the connection, the orphaned stream emits an unhandled `error` and the process exits. A remote, unauthenticated server can therefore deny service to any client that opens a WebSocket to it over HTTP/2. undici 8.11.0 and 8.11.1 are affected; the regression was introduced in 8.11.0.

Patches Upgrade to `8.11.2`.

Workarounds Set `allowH2: false` to disable HTTP/2 for WebSocket connections, or avoid opening WebSocket connections to untrusted servers, until upgrading.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-qq8j-7v2v-3rwp

  2. Revision 1 · created ·

    Published from ghsa record GHSA-qq8j-7v2v-3rwp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-109855

Advisory: undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake
IDs: CVE-2026-109855, GHSA-qq8j-7v2v-3rwp
Record: https://patchnext.com/advisories/cve-2026-109855 (revision 2, source checked 28 Oct 2026, 06:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: undici 8.11.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm undici: affected >= 8.11.0, < 8.11.2; fixed in 8.11.2

## Suggested inspection (read-only)
- `npm ls undici --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on undici.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qq8j-7v2v-3rwp (GitHub-reviewed advisory GHSA-qq8j-7v2v-3rwp lists affected ranges: npm undici >=8.11.0 <8.11.2)
- Verified: https://osv.dev/vulnerability/GHSA-qq8j-7v2v-3rwp (OSV record GHSA-qq8j-7v2v-3rwp lists affected ranges: npm undici >=8.11.0 <8.11.2 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…