undici vulnerable to Subresource Integrity bypass via non-lowercase algorithm tokens
CVE-2026-109841GHSA-f72v-6w45-q472
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (undici 8.12.2, 7.30.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm undici
- Affected
- >= 7.15.0, < 7.30.1>= 8.0.0, < 8.12.2
- Fixed in
- 8.12.2, 7.30.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f72v-6w45-q472 lists affected ranges: npm undici >=7.15.0 =8.0.0 <8.12.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-f72v-6w45-q472 lists affected ranges: npm undici >=7.15.0 =8.0.0 <8.12.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2026-109841: 0.25% estimated exploitation activity in the next 30 days; percentile 16.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact undici's fetch() verifies Subresource Integrity (SRI) metadata by looking up the algorithm token in a lowercase-only set, but the SRI specification defines a valid token by its ASCII-lowercase form. A correct but non-lowercase token such as SHA256-... or Sha256-... is therefore treated as unknown and skipped. When no recognized algorithm remains, undici treats the integrity list as empty and accepts the response, so a server that returns a body different from the pinned digest passes the check. An application that pins a response with a valid uppercase or mixed-case SRI token receives attacker-controlled bytes with no integrity error. The attacker needs only to control the response body, not the application's integrity metadata. The issue affects response integrity only. The regression was introduced in undici 7.15.0; releases 7.14.0 and earlier lowercase the token and are not affected. Patches Upgrade to 7.30.1 or 8.12.2. undici now normalizes the algorithm token to ASCII…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-f72v-6w45-q472
- Revision 2 · amended ·
Amended from osv record GHSA-f72v-6w45-q472
- Revision 1 · created ·
Published from ghsa record GHSA-f72v-6w45-q472
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-109841 Advisory: undici vulnerable to Subresource Integrity bypass via non-lowercase algorithm tokens IDs: CVE-2026-109841, GHSA-f72v-6w45-q472 Record: https://patchnext.com/advisories/cve-2026-109841 (revision 3, source checked 26 Oct 2026, 13:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: undici 8.12.2, 7.30.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm undici: affected >= 7.15.0, < 7.30.1; >= 8.0.0, < 8.12.2; fixed in 8.12.2, 7.30.1 ## Suggested inspection (read-only) - `npm ls undici --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on undici. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-f72v-6w45-q472 (GitHub-reviewed advisory GHSA-f72v-6w45-q472 lists affected ranges: npm undici >=7.15.0 =8.0.0 <8.12.2) - Verified: https://osv.dev/vulnerability/GHSA-f72v-6w45-q472 (OSV record GHSA-f72v-6w45-q472 lists affected ranges: npm undici >=7.15.0 =8.0.0 <8.12.2 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…