Skip to content

← Actionable
High, CVSS 7.4amended

undici vulnerable to cache poisoning and cross-user disclosure via cross-origin redirects

CVE-2026-109829GHSA-4w7w-5xrc-9h26

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (undici 8.12.2, 7.30.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm undici

    Affected
    >= 7.0.0, < 7.30.1>= 8.0.0, < 8.12.2
    Fixed in
    8.12.2, 7.30.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-109829: 0.15% estimated exploitation activity in the next 30 days; percentile 4.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact When an originless `Agent` composes the redirect and cache interceptors as `compose(redirect(), cache())` with a shared cache (`type: 'shared'`), the cache builds its key from the original request URL before the redirect handler changes the origin. The response produced after a redirect is then stored under the original key, even when the redirect crossed to a different origin. An attacker who controls the target of a redirect from a trusted URL can have their response cached under that trusted URL. A later caller requesting the trusted URL receives the attacker's body from the shared cache without either origin being contacted, allowing persistent cache poisoning. The same key confusion also discloses private data: when an authenticated request returns a `private, no-store` redirect to a user-specific resource, the final response is stored under the original URL and can be served to a later unauthenticated caller. The cache interceptor was introduced in undici 7.0.0, and…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-4w7w-5xrc-9h26

  2. Revision 1 · created ·

    Published from ghsa record GHSA-4w7w-5xrc-9h26

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-109829

Advisory: undici vulnerable to cache poisoning and cross-user disclosure via cross-origin redirects
IDs: CVE-2026-109829, GHSA-4w7w-5xrc-9h26
Record: https://patchnext.com/advisories/cve-2026-109829 (revision 2, source checked 28 Oct 2026, 06:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: undici 8.12.2, 7.30.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm undici: affected >= 7.0.0, < 7.30.1; >= 8.0.0, < 8.12.2; fixed in 8.12.2, 7.30.1

## Suggested inspection (read-only)
- `npm ls undici --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on undici.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4w7w-5xrc-9h26 (GitHub-reviewed advisory GHSA-4w7w-5xrc-9h26 lists affected ranges: npm undici >=7.0.0 =8.0.0 <8.12.2)
- Verified: https://osv.dev/vulnerability/GHSA-4w7w-5xrc-9h26 (OSV record GHSA-4w7w-5xrc-9h26 lists affected ranges: npm undici >=7.0.0 =8.0.0 <8.12.2 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…