Skip to content

← Actionable
Critical, CVSS 9.2Exploited · CISA KEVamended

RCE via stale global state

CVE-2026-109619

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (php 8.5.12, 8.4.27, 8.3.36, 8.2.35; libphp 8.5.12, 8.4.27, 8.3.36, 8.2.35; php-min 8.5.12, 8.4.27, 8.3.36, 8.2.35), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Bitnami php

    Affected
    >= 5.4.0, < 8.2.35>= 8.3.0, < 8.3.36>= 8.4.0, < 8.4.27>= 8.5.0, < 8.5.12
    Fixed in
    8.5.12, 8.2.35, 8.4.27, 8.3.36
  • Bitnami libphp

    Affected
    >= 5.4.0, < 8.2.35>= 8.3.0, < 8.3.36>= 8.4.0, < 8.4.27>= 8.5.0, < 8.5.12
    Fixed in
    8.5.12, 8.2.35, 8.4.27, 8.3.36
  • Bitnami php-min

    Affected
    >= 5.4.0, < 8.2.35>= 8.3.0, < 8.3.36>= 8.4.0, < 8.4.27>= 8.5.0, < 8.5.12
    Fixed in
    8.5.12, 8.2.35, 8.4.27, 8.3.36

Sources

Severity and exploitation
Exploitation
Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
CVSS 4.0
9.2 · CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X · score source
EPSS
  • CVE-2026-109619: 100.00% estimated exploitation activity in the next 30 days; percentile 100.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

PHP has various global state that temporarily points into request memory. In some scenarios, global state may not be correctly reset, or may be repopulated after being reset. The global state may then refer to request memory even after it has been freed. Subsequent requests may read or branch on this stale state before it is fully initialized. Multiple strategies can trigger this condition and produce remote code execution (RCE).

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 7 · amended ·

    Amended from osv record BIT-libphp-2026-109619

  2. Revision 6 · amended ·

    Amended from osv record BIT-php-min-2026-109619

  3. Revision 5 · amended ·

    Amended from osv record BIT-php-2026-109619

  4. Revision 4 · evidence added ·

    CISA KEV confirmed exploitation for CVE-2026-109619 (date added 2026-10-26). Customer workflow unchanged.

  5. Revision 3 · amended ·

    Amended from osv record BIT-php-2026-109619

  6. Revision 2 · amended ·

    Amended from osv record BIT-libphp-2026-109619

  7. Revision 1 · created ·

    Published from osv record BIT-php-min-2026-109619

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-109619

Advisory: RCE via stale global state
IDs: CVE-2026-109619
Record: https://patchnext.com/advisories/cve-2026-109619 (revision 7, source checked 30 Oct 2026, 07:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.2)
Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
Vendor response: Vendor fix available; fixed versions by package: php 8.5.12, 8.4.27, 8.3.36, 8.2.35; libphp 8.5.12, 8.4.27, 8.3.36, 8.2.35; php-min 8.5.12, 8.4.27, 8.3.36, 8.2.35. A vendor fix does not mean a deployment is fixed.

## Affected components
- Bitnami php: affected >= 5.4.0, < 8.2.35; >= 8.3.0, < 8.3.36; >= 8.4.0, < 8.4.27; >= 8.5.0, < 8.5.12; fixed in 8.5.12, 8.2.35, 8.4.27, 8.3.36
- Bitnami libphp: affected >= 5.4.0, < 8.2.35; >= 8.3.0, < 8.3.36; >= 8.4.0, < 8.4.27; >= 8.5.0, < 8.5.12; fixed in 8.5.12, 8.2.35, 8.4.27, 8.3.36
- Bitnami php-min: affected >= 5.4.0, < 8.2.35; >= 8.3.0, < 8.3.36; >= 8.4.0, < 8.4.27; >= 8.5.0, < 8.5.12; fixed in 8.5.12, 8.2.35, 8.4.27, 8.3.36

## Suggested inspection (read-only)
- Bitnami php: check the installed version with your package manager.
- Bitnami libphp: check the installed version with your package manager.
- Bitnami php-min: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on php, libphp, php-min.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/BIT-php-min-2026-109619 (OSV record BIT-php-min-2026-109619 lists affected ranges: Bitnami php-min >=5.4.0 =8.3.0 =8.4.0 =8.5.0 <8.5.12 (fixed))
- Verified: https://osv.dev/vulnerability/BIT-libphp-2026-109619 (OSV record BIT-libphp-2026-109619 lists affected ranges: Bitnami libphp >=5.4.0 =8.3.0 =8.4.0 =8.5.0 <8.5.12 (fixed))
- Verified: https://osv.dev/vulnerability/BIT-php-2026-109619 (OSV record BIT-php-2026-109619 lists affected ranges: Bitnami php >=5.4.0 =8.3.0 =8.4.0 =8.5.0 <8.5.12 (fixed))
- Verified: https://www.cisa.gov/sites/default/files/feeds/known_exploited_vulnerabilities.json (CISA added CVE-2026-109619 to the Known Exploited Vulnerabilities catalog on 2026-10-26.)

Commands are suggestions: review each one before running it.

Loading voting…