Symfony: Unbounded Recursion in the YAML Inline Lexer Lets a Single Document Crash the Process
CVE-2026-109413GHSA-2v3c-qxhr-7vpv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (symfony/symfony 8.1.6, 7.4.18, 6.4.45, 5.4.54; symfony/yaml 8.1.6, 7.4.18, 6.4.45, 5.4.54), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist symfony/symfony
- Affected
- >= 2.0.0, < 5.4.54>= 6.0.0, < 6.4.45>= 7.0.0, < 7.4.18>= 8.0.0, < 8.1.6
- Fixed in
- 8.1.6, 5.4.54, 7.4.18, 6.4.45
Packagist symfony/yaml
- Affected
- >= 2.0.0, < 5.4.54>= 6.0.0, < 6.4.45>= 7.0.0, < 7.4.18>= 8.0.0, < 8.1.6
- Fixed in
- 8.1.6, 5.4.54, 7.4.18, 6.4.45
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2v3c-qxhr-7vpv lists affected ranges: Packagist symfony/symfony >=2.0.0 =6.0.0 =7.0.0 =8.0.0 =2.0.0 =6.0.0 =7.0.0 =8.0.0 <8.1.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-2v3c-qxhr-7vpv lists affected ranges: Packagist symfony/symfony >=2.0.0 =6.0.0 =7.0.0 =8.0.0 =2.0.0 =6.0.0 =7.0.0 =8.0.0 <8.1.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-109413: 0.40% estimated exploitation activity in the next 30 days; percentile 33.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description `Yaml\Parser::lexInlineStructure()` recursed through `lexInlineMapping()` and `lexInlineSequence()` for every `{` and `[` of an inline collection, without entering the nesting level that the rest of the parser bounds with `maxNestingLevel`. A document made of deeply nested inline collections, such as `[[[[...]]]]`, exhausted the stack while it was being lexed: depending on the PHP version and its stack settings, the process crashed or the request ended with a fatal error. Any code parsing untrusted YAML is affected. That includes `#[MapRequestPayload]` when the Yaml component is installed and the endpoint does not restrict `acceptFormat`: a single unauthenticated request with a YAML content type is enough.
Resolution The inline lexer now enters and leaves the same nesting level as the rest of the parser, so nested inline collections are bounded by `maxNestingLevel`, and the parser raises a `ParseException` beyond it. The patches for this issue are available…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from osv record GHSA-2v3c-qxhr-7vpv
- Revision 1 · created ·
Published from ghsa record GHSA-2v3c-qxhr-7vpv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-109413 Advisory: Symfony: Unbounded Recursion in the YAML Inline Lexer Lets a Single Document Crash the Process IDs: CVE-2026-109413, GHSA-2v3c-qxhr-7vpv Record: https://patchnext.com/advisories/cve-2026-109413 (revision 2, source checked 28 Oct 2026, 06:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: symfony/symfony 8.1.6, 7.4.18, 6.4.45, 5.4.54; symfony/yaml 8.1.6, 7.4.18, 6.4.45, 5.4.54. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist symfony/symfony: affected >= 2.0.0, < 5.4.54; >= 6.0.0, < 6.4.45; >= 7.0.0, < 7.4.18; >= 8.0.0, < 8.1.6; fixed in 8.1.6, 5.4.54, 7.4.18, 6.4.45 - Packagist symfony/yaml: affected >= 2.0.0, < 5.4.54; >= 6.0.0, < 6.4.45; >= 7.0.0, < 7.4.18; >= 8.0.0, < 8.1.6; fixed in 8.1.6, 5.4.54, 7.4.18, 6.4.45 ## Suggested inspection (read-only) - Packagist symfony/symfony: check the installed version with your package manager. - Packagist symfony/yaml: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on symfony/symfony, symfony/yaml. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2v3c-qxhr-7vpv (GitHub-reviewed advisory GHSA-2v3c-qxhr-7vpv lists affected ranges: Packagist symfony/symfony >=2.0.0 =6.0.0 =7.0.0 =8.0.0 =2.0.0 =6.0.0 =7.0.0 =8.0.0 <8.1.6) - Verified: https://osv.dev/vulnerability/GHSA-2v3c-qxhr-7vpv (OSV record GHSA-2v3c-qxhr-7vpv lists affected ranges: Packagist symfony/symfony >=2.0.0 =6.0.0 =7.0.0 =8.0.0 =2.0.0 =6.0.0 =7.0.0 =8.0.0 <8.1.6 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…