undici vulnerable to TLS certificate validation bypass via dropped tls options in Agent
CVE-2026-109383GHSA-2m5v-pch6-74hx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (undici 8.12.2, 7.30.1, 6.29.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm undici
- Affected
- >= 4.0.0, < 6.29.1>= 7.0.0, < 7.30.1>= 8.0.0, < 8.12.2
- Fixed in
- 8.12.2, 6.29.1, 7.30.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2m5v-pch6-74hx lists affected ranges: npm undici >=4.0.0 =7.0.0 =8.0.0 <8.12.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-2m5v-pch6-74hx lists affected ranges: npm undici >=4.0.0 =7.0.0 =8.0.0 <8.12.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-109383: 0.18% estimated exploitation activity in the next 30 days; percentile 8.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact undici's `Agent` passes its constructor options through a JSON-based deep clone (`JSON.parse(JSON.stringify(...))`) before forwarding them to each per-origin `Pool`. JSON cannot represent functions, so a caller-supplied `tls` option containing a `checkServerIdentity` callback is silently dropped before it reaches the TLS layer. As a result, a TLS peer whose certificate a custom `checkServerIdentity` was written to reject, but which passes Node's default hostname and chain checks, is silently accepted when the request is made through `Agent`. Because `Agent` is the default dispatcher behind `request`, `fetch`, and `setGlobalDispatcher`, this is the path most applications use. `EnvHttpProxyAgent` is also affected on its direct and `NO_PROXY` routes, which delegate to an internal `Agent`. Only applications that pass a function-valued `tls` option (such as a custom `checkServerIdentity` for certificate or public-key pinning) are affected. Passing the same options through…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from osv record GHSA-2m5v-pch6-74hx
- Revision 1 · created ·
Published from ghsa record GHSA-2m5v-pch6-74hx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-109383 Advisory: undici vulnerable to TLS certificate validation bypass via dropped tls options in Agent IDs: CVE-2026-109383, GHSA-2m5v-pch6-74hx Record: https://patchnext.com/advisories/cve-2026-109383 (revision 2, source checked 28 Oct 2026, 06:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: undici 8.12.2, 7.30.1, 6.29.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm undici: affected >= 4.0.0, < 6.29.1; >= 7.0.0, < 7.30.1; >= 8.0.0, < 8.12.2; fixed in 8.12.2, 6.29.1, 7.30.1 ## Suggested inspection (read-only) - `npm ls undici --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on undici. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2m5v-pch6-74hx (GitHub-reviewed advisory GHSA-2m5v-pch6-74hx lists affected ranges: npm undici >=4.0.0 =7.0.0 =8.0.0 <8.12.2) - Verified: https://osv.dev/vulnerability/GHSA-2m5v-pch6-74hx (OSV record GHSA-2m5v-pch6-74hx lists affected ranges: npm undici >=4.0.0 =7.0.0 =8.0.0 <8.12.2 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…