Skip to content

← Actionable
High, CVSS 7.1amended

LoopX serve-status permissive CORS policy exposes control-plane state and private Markdown files

CVE-2026-108372GHSA-vx2m-gpq4-8j5q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (loopx 0.4.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI loopx

    Affected
    >= 0.0.1, < 0.4.5
    Fixed in
    0.4.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-108372: 0.30% estimated exploitation activity in the next 30 days; percentile 23.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary loopx serve-status sends Access-Control-Allow-Origin: on every response, including its unauthenticated GET routes. Because the endpoint is unauthenticated and bound to a fixed, well-known loopback port, any website the operator visits can read LoopX control-plane state and the contents of Markdown files inside every registered goal repo, using a plain fetch() with no user interaction. The write endpoints are not affected — they are correctly Origin-checked. This report is strictly about the read paths. Impact While loopx serve-status is running, a page on any origin can run: and read back: GET /status.json — the whole status projection: goal ids, run history, and local absolute paths (registry, runtimeroot). With --global-registry this covers every project registered on the machine, not just one. GET /review-material?goalid=…&path=… — the content of any .md/.markdown file under a goal's repo root, state dir, or runtime dir. In practice that is the operator's private design…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-vx2m-gpq4-8j5q

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-vx2m-gpq4-8j5q

  4. Revision 1 · created ·

    Published from ghsa record GHSA-vx2m-gpq4-8j5q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-108372

Advisory: LoopX serve-status permissive CORS policy exposes control-plane state and private Markdown files
IDs: CVE-2026-108372, GHSA-vx2m-gpq4-8j5q
Record: https://patchnext.com/advisories/cve-2026-108372 (revision 4, source checked 26 Oct 2026, 13:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: loopx 0.4.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI loopx: affected >= 0.0.1, < 0.4.5; fixed in 0.4.5

## Suggested inspection (read-only)
- `python -m pip show loopx`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on loopx.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vx2m-gpq4-8j5q (GitHub-reviewed advisory GHSA-vx2m-gpq4-8j5q lists affected ranges: PyPI loopx >=0.0.1 <0.4.5)
- Verified: https://osv.dev/vulnerability/GHSA-vx2m-gpq4-8j5q (OSV record GHSA-vx2m-gpq4-8j5q lists affected ranges: PyPI loopx >=0.0.1 <0.4.5 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…