Skip to content

← Actionable
High, CVSS 8.7amended

PhpSpreadsheet ODS Reader: Unbounded number-rows-repeated → CPU & Memory Exhaustion (DoS)

CVE-2026-108359GHSA-j2w7-387v-m2rq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpoffice/phpspreadsheet 5.10.0, 3.10.8, 2.4.8, 2.1.19, 1.30.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist phpoffice/phpspreadsheet

    Affected
    >= 4.0.0, < 5.10.0>= 3.3.0, < 3.10.8>= 2.2.0, < 2.4.8>= 2.0.0, < 2.1.19< 1.30.7
    Fixed in
    3.10.8, 2.4.8, 2.1.19, 1.30.7, 5.10.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-108359: 0.66% estimated exploitation activity in the next 30 days; percentile 51.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary When PhpSpreadsheet loads an OpenDocument Spreadsheet (`.ods`), `Ods::processTableRow()` reads the `table:number-rows-repeated` attribute of a ` ` with an unchecked `(int)` cast, then materialises one cell per repeated row. This value is completely unbounded, so a single ~1.4 KB file can instruct the reader to create up to millions of cells, exhausting memory (fatal OOM). No authentication, no special configuration, and the default read filter are required - any application that loads a user-supplied `.ods` is affected. ---

Affected versions The `number-rows-repeated` expansion has existed in the ODS reader since its inception (pre-dating the current release branches), so all maintained lines are affected. | Branch | Affected | |--------|----------| | 1.x | ≤ 1.30.6 | | 2.0–2.1 | ≤ 2.1.18 | | 2.2–2.4 | ≤ 2.4.7 | | 3.x | ≤ 3.10.7 | | 4.x–5.x | ≤ 5.9.0 (latest) | ---

Root cause (source → sink) `src/PhpSpreadsheet/Reader/Ods.php`: ```php // line 816 — row…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-j2w7-387v-m2rq

  2. Revision 1 · created ·

    Published from ghsa record GHSA-j2w7-387v-m2rq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-108359

Advisory: PhpSpreadsheet ODS Reader: Unbounded number-rows-repeated → CPU & Memory Exhaustion (DoS)
IDs: CVE-2026-108359, GHSA-j2w7-387v-m2rq
Record: https://patchnext.com/advisories/cve-2026-108359 (revision 2, source checked 28 Oct 2026, 06:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: phpoffice/phpspreadsheet 5.10.0, 3.10.8, 2.4.8, 2.1.19, 1.30.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist phpoffice/phpspreadsheet: affected >= 4.0.0, < 5.10.0; >= 3.3.0, < 3.10.8; >= 2.2.0, < 2.4.8; >= 2.0.0, < 2.1.19; < 1.30.7; fixed in 3.10.8, 2.4.8, 2.1.19, 1.30.7, 5.10.0

## Suggested inspection (read-only)
- Packagist phpoffice/phpspreadsheet: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on phpoffice/phpspreadsheet.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-j2w7-387v-m2rq (GitHub-reviewed advisory GHSA-j2w7-387v-m2rq lists affected ranges: Packagist phpoffice/phpspreadsheet >=4.0.0 =3.3.0 =2.2.0 =2.0.0 =0 <=1.30.6)
- Verified: https://osv.dev/vulnerability/GHSA-j2w7-387v-m2rq (OSV record GHSA-j2w7-387v-m2rq lists affected ranges: Packagist phpoffice/phpspreadsheet >=4.0.0 =3.3.0 =2.2.0 =2.0.0 =0 <1.30.7 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…