Skip to content

← Actionable
High, CVSS 8.8amended

PhpSpreadsheet: XmlScanner Bypass via ISO-2022 Escape Sequences Allows XXE and Denial of Service

CVE-2026-108358GHSA-3x94-m842-937c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpoffice/phpspreadsheet 5.10.0, 3.10.8, 2.4.8, 2.1.19, 1.30.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist phpoffice/phpspreadsheet

    Affected
    >= 4.0.0, < 5.10.0>= 3.3.0, < 3.10.8>= 2.2.0, < 2.4.8>= 2.0.0, < 2.1.19< 1.30.7
    Fixed in
    3.10.8, 2.4.8, 2.1.19, 1.30.7, 5.10.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:H/SC:L/SI:N/SA:N · score source
EPSS
  • CVE-2026-108358: 0.63% estimated exploitation activity in the next 30 days; percentile 50.03 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary PhpSpreadsheet's `XmlScanner::scan()` uses a regex pattern that only accounts for NULL byte (0x00) interleaving when detecting ` ' . "\n" . $doctype . ' sst [' . "\n" . ' ' . "\n" . ']>' . "\n" . ' ' . ' ' . $refs . ' '; // Build minimal XLSX $xlsx = new ZipArchive(); $xlsx->open('poc.xlsx', ZipArchive::CREATE | ZipArchive::OVERWRITE); $xlsx->addFromString('[Content_Types].xml', ' ' .' ' .' ' .' ' .' ' .' ' .' '); $xlsx->addFromString('_rels/.rels', ' ' .' ' .' '); $xlsx->addFromString('xl/workbook.xml', ' ' .' '); $xlsx->addFromString('xl/_rels/workbook.xml.rels', ' ' .' ' .' ' .' '); $xlsx->addFromString('xl/worksheets/sheet1.xml', ' ' .' 0 '); $xlsx->addFromString('xl/sharedStrings.xml', $shared_strings); $xlsx->close(); echo "XLSX size: " . filesize('poc.xlsx') . " bytes\n"; // Load with PhpSpreadsheet $mem_before = memory_get_usage(true); $reader = new \PhpOffice\PhpSpreadsheet\Reader\Xlsx(); $reader->setReadDataOnly(true); $spreadsheet = $reader->load('poc.xlsx');…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-3x94-m842-937c

  2. Revision 1 · created ·

    Published from ghsa record GHSA-3x94-m842-937c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-108358

Advisory: PhpSpreadsheet: XmlScanner Bypass via ISO-2022 Escape Sequences Allows XXE and Denial of Service
IDs: CVE-2026-108358, GHSA-3x94-m842-937c
Record: https://patchnext.com/advisories/cve-2026-108358 (revision 2, source checked 28 Oct 2026, 06:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: phpoffice/phpspreadsheet 5.10.0, 3.10.8, 2.4.8, 2.1.19, 1.30.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist phpoffice/phpspreadsheet: affected >= 4.0.0, < 5.10.0; >= 3.3.0, < 3.10.8; >= 2.2.0, < 2.4.8; >= 2.0.0, < 2.1.19; < 1.30.7; fixed in 3.10.8, 2.4.8, 2.1.19, 1.30.7, 5.10.0

## Suggested inspection (read-only)
- Packagist phpoffice/phpspreadsheet: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on phpoffice/phpspreadsheet.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3x94-m842-937c (GitHub-reviewed advisory GHSA-3x94-m842-937c lists affected ranges: Packagist phpoffice/phpspreadsheet >=4.0.0 =3.3.0 =2.2.0 =2.0.0 =0 <=1.30.6)
- Verified: https://osv.dev/vulnerability/GHSA-3x94-m842-937c (OSV record GHSA-3x94-m842-937c lists affected ranges: Packagist phpoffice/phpspreadsheet >=4.0.0 =3.3.0 =2.2.0 =2.0.0 =0 <1.30.7 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…