PhpSpreadsheet: XmlScanner Bypass via Double-Encoded unentity() TOCTOU Allows XXE and Denial of Service
CVE-2026-108357GHSA-rxj4-h86g-25gc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpoffice/phpspreadsheet 5.10.0, 3.10.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist phpoffice/phpspreadsheet
- Affected
- >= 4.0.0, < 5.10.0>= 3.3.0, < 3.10.8
- Fixed in
- 3.10.8, 5.10.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rxj4-h86g-25gc lists affected ranges: Packagist phpoffice/phpspreadsheet >=4.0.0 =3.3.0 <=3.10.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-rxj4-h86g-25gc lists affected ranges: Packagist phpoffice/phpspreadsheet >=4.0.0 =3.3.0 <3.10.8 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:H/SC:L/SI:N/SA:N · score source
- EPSS
- CVE-2026-108357: 0.46% estimated exploitation activity in the next 30 days; percentile 40.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The SpreadsheetML XML reader (`Reader\Xml`) scans file content twice through `XmlScanner::scan()`, and each scan runs an `unentity()` callback that calls `html_entity_decode()` after the pattern check. By double-encoding the ` toUtf8($xml); if (preg_match($pattern, $xml)) { // CHECK 2 (UTF-8) throw new Exception('Detected use of ENTITY...'); } if ($this->callback !== null) { $xml = call_user_func($this->callback, $xml); // DECODE (after checks!) } return $xml; // getSecurityScannerOrThrow()->scan($data); // 1st scan // ... $this->fileContents = $data; // stores partially-decoded content ``` 3. `Xml::trySimpleXMLLoadStringPrivate()` (Xml.php, lines 120–150) — re-scans the stored content: ```php $data = $this->fileContents; // already partially decoded $xml = simplexml_load_string( $this->getSecurityScannerOrThrow()->scan($data) // 2nd scan finishes decoding ); ``` The double-scan decode chain: ``` Raw file: &#60;!DOCTYPE | 1st scan(): pattern check → no…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from osv record GHSA-rxj4-h86g-25gc
- Revision 1 · created ·
Published from ghsa record GHSA-rxj4-h86g-25gc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-108357 Advisory: PhpSpreadsheet: XmlScanner Bypass via Double-Encoded unentity() TOCTOU Allows XXE and Denial of Service IDs: CVE-2026-108357, GHSA-rxj4-h86g-25gc Record: https://patchnext.com/advisories/cve-2026-108357 (revision 2, source checked 28 Oct 2026, 06:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: phpoffice/phpspreadsheet 5.10.0, 3.10.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist phpoffice/phpspreadsheet: affected >= 4.0.0, < 5.10.0; >= 3.3.0, < 3.10.8; fixed in 3.10.8, 5.10.0 ## Suggested inspection (read-only) - Packagist phpoffice/phpspreadsheet: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on phpoffice/phpspreadsheet. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rxj4-h86g-25gc (GitHub-reviewed advisory GHSA-rxj4-h86g-25gc lists affected ranges: Packagist phpoffice/phpspreadsheet >=4.0.0 =3.3.0 <=3.10.7) - Verified: https://osv.dev/vulnerability/GHSA-rxj4-h86g-25gc (OSV record GHSA-rxj4-h86g-25gc lists affected ranges: Packagist phpoffice/phpspreadsheet >=4.0.0 =3.3.0 <3.10.8 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…