snappy-java: Unbounded memory allocation from attacker-declared uncompressed lengtha
CVE-2026-108106GHSA-q233-g92q-qxp6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xerial.snappy:snappy-java 1.1.10.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.xerial.snappy:snappy-java
- Affected
- < 1.1.10.9
- Fixed in
- 1.1.10.9
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q233-g92q-qxp6 lists affected ranges: Maven org.xerial.snappy:snappy-java >=0 <=1.1.10.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-q233-g92q-qxp6 lists affected ranges: Maven org.xerial.snappy:snappy-java >=0 <1.1.10.9 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-108106: 0.37% estimated exploitation activity in the next 30 days; percentile 31.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Several decompression paths in snappy-java allocate an output buffer sized by the uncompressed length declared in the first bytes of the compressed data, before decompressing or validating it. A few bytes of crafted input can therefore force an allocation of up to 2 GB, causing `OutOfMemoryError` (denial of service), or a `NegativeArraySizeException` for declared lengths of 2^31 or more. Affected entry points include `Snappy.uncompress(byte[])`, `Snappy.uncompressString`, the `Snappy.uncompress*Array` methods, `SnappyInputStream`, and `SnappyFramedInputStream`. The `maxChunkSize` limit added for CVE-2023-43642 bounds only the compressed chunk length, so it does not prevent this.
Patches Fixed in 1.1.10.9 (#739). `Snappy.uncompressedLength()` now rejects negative declared lengths, and lengths larger than any valid Snappy stream of the given size can produce. The densest Snappy element expands 3 bytes to 64, so the limit is 64/3 of the compressed size. Allocations are…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from osv record GHSA-q233-g92q-qxp6
- Revision 1 · created ·
Published from ghsa record GHSA-q233-g92q-qxp6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-108106 Advisory: snappy-java: Unbounded memory allocation from attacker-declared uncompressed lengtha IDs: CVE-2026-108106, GHSA-q233-g92q-qxp6 Record: https://patchnext.com/advisories/cve-2026-108106 (revision 2, source checked 28 Oct 2026, 06:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.xerial.snappy:snappy-java 1.1.10.9. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.xerial.snappy:snappy-java: affected < 1.1.10.9; fixed in 1.1.10.9 ## Suggested inspection (read-only) - Maven org.xerial.snappy:snappy-java: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.xerial.snappy:snappy-java. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-q233-g92q-qxp6 (GitHub-reviewed advisory GHSA-q233-g92q-qxp6 lists affected ranges: Maven org.xerial.snappy:snappy-java >=0 <=1.1.10.8) - Verified: https://osv.dev/vulnerability/GHSA-q233-g92q-qxp6 (OSV record GHSA-q233-g92q-qxp6 lists affected ranges: Maven org.xerial.snappy:snappy-java >=0 <1.1.10.9 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…