Skip to content

← Actionable
Unrated

DRUPAL-CORE-2026-014

CVE-2026-108097

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (drupal/core 12.0.0-beta2, 11.4.10, 11.3.19, 10.6.19), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist drupal/core

    Affected
    >= 8.9.0, < 10.6.19>= 11.0.0, < 11.3.19>= 11.4.0, < 11.4.10>= 12.0.0-alpha1, < 12.0.0-beta2
    Fixed in
    10.6.19, 11.3.19, 11.4.10, 12.0.0-beta2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2026-108097: 0.33% estimated exploitation activity in the next 30 days; percentile 25.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A remote code execution vulnerability exists within the Field UI module in Drupal core. The vulnerability is not directly exploitable with core alone, but multiple serious exploit paths exist with contributed modules. At least one known exploit path does not require authentication. Custom code may also expose the vulnerable functionality. The vulnerability can be mitigated by uninstalling the core Field UI module (`field_ui`), which will provide protection while sites are updated.

Drupal Steward protection: This issue is being protected by Drupal Steward. Sites that use Drupal Steward are already protected from some known attack vectors, but the protection offered will not cover all possible exploits. Sites should upgrade in the near future in case additional attack vectors are discovered.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from osv record DRUPAL-CORE-2026-014

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-108097

Advisory: DRUPAL-CORE-2026-014
IDs: CVE-2026-108097
Record: https://patchnext.com/advisories/cve-2026-108097 (revision 1, source checked 23 Oct 2026, 22:04 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: drupal/core 12.0.0-beta2, 11.4.10, 11.3.19, 10.6.19. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist drupal/core: affected >= 8.9.0, < 10.6.19; >= 11.0.0, < 11.3.19; >= 11.4.0, < 11.4.10; >= 12.0.0-alpha1, < 12.0.0-beta2; fixed in 10.6.19, 11.3.19, 11.4.10, 12.0.0-beta2

## Suggested inspection (read-only)
- Packagist drupal/core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on drupal/core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/DRUPAL-CORE-2026-014 (OSV record DRUPAL-CORE-2026-014 lists affected ranges: Packagist drupal/core >=8.9.0 =11.0.0 =11.4.0 =12.0.0-alpha1 <12.0.0-beta2 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…