Skip to content

← Actionable
Medium, CVSS 4.3amended

Contao: Improper access control in the table access voter

CVE-2026-107851GHSA-5974-gfqc-wrcm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (contao/core-bundle 5.7.12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2026-107851: 0.19% estimated exploitation activity in the next 30 days; percentile 9.06 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Due to a caching defect in the security voter that governs table-level access to Contao's Data Container (DCA) backend, a low-privileged, non-admin backend user can obtain unauthorized read, create, update, and delete access to database tables outside their assigned module permissions. This includes tables containing sensitive personal data, such as frontend member records and newsletter subscriber e-mail addresses. Vulnerability Details In plain terms: Contao's backend is organized into modules (e.g. "News", "Members"). Every backend user is assigned to a group, and that group decides which modules, and therefore which database tables, they are allowed to work with. Before Contao lets a user touch a table, it is supposed to check: "does this user's group actually include this table?" To avoid doing that check over and over, Contao remembers the answer for the rest of the request. The problem is that it remembers the answer under the wrong label. Instead of remembering "is this user…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-5974-gfqc-wrcm

  2. Revision 1 · created ·

    Published from osv record GHSA-5974-gfqc-wrcm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-107851

Advisory: Contao: Improper access control in the table access voter
IDs: CVE-2026-107851, GHSA-5974-gfqc-wrcm
Record: https://patchnext.com/advisories/cve-2026-107851 (revision 2, source checked 26 Oct 2026, 14:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: contao/core-bundle 5.7.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist contao/core-bundle: affected >= 5.7.0, < 5.7.12; fixed in 5.7.12

## Suggested inspection (read-only)
- Packagist contao/core-bundle: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on contao/core-bundle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5974-gfqc-wrcm (OSV record GHSA-5974-gfqc-wrcm lists affected ranges: Packagist contao/core-bundle >=5.7.0 <5.7.12 (fixed))
- Verified: https://github.com/advisories/GHSA-5974-gfqc-wrcm (GitHub-reviewed advisory GHSA-5974-gfqc-wrcm lists affected ranges: Packagist contao/core-bundle >=5.7.0 <5.7.12)

Commands are suggestions: review each one before running it.

Loading voting…