Skip to content

← Actionable
Low, CVSS 3.5amended

Contao: Cross-site request forgery in custom backend actions

CVE-2026-107848GHSA-9ff2-p842-45wq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (contao/core-bundle 5.7.12, 5.3.50), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist contao/core-bundle

    Affected
    >= 4.0.0, < 5.3.50>= 5.4.0-RC1, < 5.7.12
    Fixed in
    5.7.12, 5.3.50

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
EPSS
  • CVE-2026-107848: 0.11% estimated exploitation activity in the next 30 days; percentile 1.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

RequestTokenListener is the only generic REQUESTTOKEN validator in Contao and it only runs on POST. On the GET side the guard is local and declarative, and it only fires when an act parameter is present. Every back end action dispatched through a different parameter therefore has no CSRF protection at all. This is a family rather than a single bug. Impact An attacker who gets a logged in back end user to load a URL performs back end actions as that user, with no token and no confirmation. Because the exposure follows from the dispatch mechanism rather than from one callback, every present and future key= action inherits it. Honest bound. The victim must be authenticated in the back end and must load the URL, and the reachable actions are limited to the modules that user can access. We have not found a key= action that grants privileges; the ones we verified are destructive or state changing rather than escalating.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-9ff2-p842-45wq

  2. Revision 1 · created ·

    Published from osv record GHSA-9ff2-p842-45wq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-107848

Advisory: Contao: Cross-site request forgery in custom backend actions
IDs: CVE-2026-107848, GHSA-9ff2-p842-45wq
Record: https://patchnext.com/advisories/cve-2026-107848 (revision 2, source checked 26 Oct 2026, 14:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: contao/core-bundle 5.7.12, 5.3.50. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist contao/core-bundle: affected >= 4.0.0, < 5.3.50; >= 5.4.0-RC1, < 5.7.12; fixed in 5.7.12, 5.3.50

## Suggested inspection (read-only)
- Packagist contao/core-bundle: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on contao/core-bundle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9ff2-p842-45wq (OSV record GHSA-9ff2-p842-45wq lists affected ranges: Packagist contao/core-bundle >=4.0.0 =5.4.0-RC1 <5.7.12 (fixed))
- Verified: https://github.com/advisories/GHSA-9ff2-p842-45wq (GitHub-reviewed advisory GHSA-9ff2-p842-45wq lists affected ranges: Packagist contao/core-bundle >=4.0.0 =5.4.0-RC1 <5.7.12)

Commands are suggestions: review each one before running it.

Loading voting…