Skip to content

← Actionable
Critical, CVSS 9.3amended

Contao: Cross-site scripting in the comments bundle

CVE-2026-107845GHSA-628f-v4f6-p37r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (contao/comments-bundle 5.7.12, 5.3.50), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N
EPSS
  • CVE-2026-107845: 0.28% estimated exploitation activity in the next 30 days; percentile 20.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

An unauthenticated front end visitor can post a comment containing a XSS injection. The victim is any back end user who opens the Comments module, and moderation makes exposure certain rather than preventing it. No Content-Security-Policy header is sent on the Contao back end, so nothing mitigates the inline handler. Impact Anyone on the internet can inject script that executes in the Contao back end origin, under the session of whichever user opens the Comments module, with no click and no hover. From there the payload acts as that user through the back end: reading any module they can reach, creating a new administrator, or editing a template, which on Contao is a documented path from back end write access to code execution. Moderation does not help and in fact guarantees exposure, since unpublished comments are still inserted and a moderator has to open the list to act on them.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-628f-v4f6-p37r

  2. Revision 1 · created ·

    Published from osv record GHSA-628f-v4f6-p37r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-107845

Advisory: Contao: Cross-site scripting in the comments bundle
IDs: CVE-2026-107845, GHSA-628f-v4f6-p37r
Record: https://patchnext.com/advisories/cve-2026-107845 (revision 2, source checked 26 Oct 2026, 14:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: contao/comments-bundle 5.7.12, 5.3.50. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist contao/comments-bundle: affected >= 4.0.0, < 5.3.50; >= 5.4.0-RC1, < 5.7.12; fixed in 5.7.12, 5.3.50

## Suggested inspection (read-only)
- Packagist contao/comments-bundle: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on contao/comments-bundle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-628f-v4f6-p37r (OSV record GHSA-628f-v4f6-p37r lists affected ranges: Packagist contao/comments-bundle >=4.0.0 =5.4.0-RC1 <5.7.12 (fixed))
- Verified: https://github.com/advisories/GHSA-628f-v4f6-p37r (GitHub-reviewed advisory GHSA-628f-v4f6-p37r lists affected ranges: Packagist contao/comments-bundle >=4.0.0 =5.4.0-RC1 <5.7.12)

Commands are suggestions: review each one before running it.

Loading voting…