Skip to content

← Actionable
Medium, CVSS 5.3amended

Contao: The registration module re-sends activation mails

CVE-2026-107843GHSA-mfxh-vp55-7gc6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (contao/core-bundle 5.7.12, 5.3.50), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist contao/core-bundle

    Affected
    >= 4.1.0, < 5.3.50>= 5.4.0-RC1, < 5.7.12
    Fixed in
    5.7.12, 5.3.50

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2026-107843: 0.27% estimated exploitation activity in the next 30 days; percentile 19.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

ModuleRegistration::compile() reaches its follow-up registration branch on any POST to a page carrying the module. That branch checks neither FORMSUBMIT nor the captcha result computed immediately above it, and resendActivationMail() leads to OptInToken::send(), which has no rate limit at all. Impact Anyone on the internet can make a Contao installation send unlimited mail to an address of their choosing, from the site's own sender and reputation, at one outbound message per HTTP request. That is both a nuisance for the recipient and a deliverability risk for the site operator. The same request is a reliable account oracle for "this address has a pending registration on this site", which is exactly the sort of membership fact a public site is usually expected not to disclose. Honest bound. The target must have an unconfirmed registration, that is tlmember.disable = 1 together with an unconfirmed reg- opt-in token. An attacker can create that state for an arbitrary address, since…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-mfxh-vp55-7gc6

  2. Revision 1 · created ·

    Published from osv record GHSA-mfxh-vp55-7gc6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-107843

Advisory: Contao: The registration module re-sends activation mails
IDs: CVE-2026-107843, GHSA-mfxh-vp55-7gc6
Record: https://patchnext.com/advisories/cve-2026-107843 (revision 2, source checked 26 Oct 2026, 14:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: contao/core-bundle 5.7.12, 5.3.50. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist contao/core-bundle: affected >= 4.1.0, < 5.3.50; >= 5.4.0-RC1, < 5.7.12; fixed in 5.7.12, 5.3.50

## Suggested inspection (read-only)
- Packagist contao/core-bundle: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on contao/core-bundle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mfxh-vp55-7gc6 (OSV record GHSA-mfxh-vp55-7gc6 lists affected ranges: Packagist contao/core-bundle >=4.1.0 =5.4.0-RC1 <5.7.12 (fixed))
- Verified: https://github.com/advisories/GHSA-mfxh-vp55-7gc6 (GitHub-reviewed advisory GHSA-mfxh-vp55-7gc6 lists affected ranges: Packagist contao/core-bundle >=4.1.0 =5.4.0-RC1 <5.7.12)

Commands are suggestions: review each one before running it.

Loading voting…