pacioli: A submit consent marker licensed cancellation of caller-named pre-existing documents
CVE-2026-107841GHSA-3hj7-6vmj-h8v4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pacioli-guard 0.10.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI pacioli-guard
- Affected
- >= 0.9.6, < 0.10.0
- Fixed in
- 0.10.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3hj7-6vmj-h8v4 lists affected ranges: PyPI pacioli-guard >=0.9.6 <0.10.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-3hj7-6vmj-h8v4 lists affected ranges: PyPI pacioli-guard >=0.9.6 <0.10.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:H/A:N
- EPSS
- CVE-2026-107841: 0.23% estimated exploitation activity in the next 30 days; percentile 14.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact pacioli-guard's document-layer consent gate requires a human-minted, single-use, document-bound and act-bound marker before a credential carrying API Key Scope.requireconsent may submit or cancel a document. Because ERPNext performs further document writes as a consequence of a governed act, nested acts are allowed to "ride" the consent established by the enclosing act instead of needing a marker of their own. The ride predicate returned true for every cancel, regardless of which act the enclosing marker authorised. Riding never reaches consentverdict, which is where the marker-to-act binding is enforced. The result: any Document.cancel() performed inside an act that had established consent reached docstatus = 2 with no marker, no act-binding check, no single-use spend, and no denial audit row. This is reachable with the exact grant an operator is documented to give the broker, and the cancelled document's identity is caller-controlled: - Sales Invoice.onsubmit…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-3hj7-6vmj-h8v4
- Revision 2 · amended ·
Amended from osv record GHSA-3hj7-6vmj-h8v4
- Revision 1 · created ·
Published from ghsa record GHSA-3hj7-6vmj-h8v4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-107841 Advisory: pacioli: A submit consent marker licensed cancellation of caller-named pre-existing documents IDs: CVE-2026-107841, GHSA-3hj7-6vmj-h8v4 Record: https://patchnext.com/advisories/cve-2026-107841 (revision 3, source checked 26 Oct 2026, 13:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pacioli-guard 0.10.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI pacioli-guard: affected >= 0.9.6, < 0.10.0; fixed in 0.10.0 ## Suggested inspection (read-only) - `python -m pip show pacioli-guard`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pacioli-guard. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-3hj7-6vmj-h8v4 (GitHub-reviewed advisory GHSA-3hj7-6vmj-h8v4 lists affected ranges: PyPI pacioli-guard >=0.9.6 <0.10.0) - Verified: https://osv.dev/vulnerability/GHSA-3hj7-6vmj-h8v4 (OSV record GHSA-3hj7-6vmj-h8v4 lists affected ranges: PyPI pacioli-guard >=0.9.6 <0.10.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…