fastify is vulnerable to header validation bypass via case-sensitive propertyNames
CVE-2026-107832GHSA-389g-gv7q-r4x8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (fastify 5.12.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm fastify
- Affected
- >= 5.12.2, < 5.12.6
- Fixed in
- 5.12.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-389g-gv7q-r4x8 lists affected ranges: npm fastify >=5.12.2 <5.12.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-389g-gv7q-r4x8 lists affected ranges: npm fastify >=5.12.2 <5.12.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N
- EPSS
- CVE-2026-107832: 0.26% estimated exploitation activity in the next 30 days; percentile 17.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Fastify lowercases header names in a headers schema before compilation, because Node.js stores request header names in lowercase. This normalization does not reach the header names held in a propertyNames subschema's enum and const. A header-name deny-list written in the canonical header case, such as propertyNames: { not: { enum: ['X-Debug-Override'] } }, therefore never matches the lowercased request headers, and the forbidden header reaches the handler. Any application that uses a propertyNames deny-list or allow-list to constrain request header names does not get the constraint it expects. The same rule written in lowercase works, and the not: { required: [...] } form is unaffected, so this is a gap in the built-in normalization rather than a wrong schema. This is an incomplete fix of CVE-2026-84428 (GHSA-9q9j-q6p8-xq58), whose normalization covered header names used as property keys but not those used as values inside propertyNames. Patches Users should upgrade to fastify…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-389g-gv7q-r4x8
- Revision 2 · amended ·
Amended from osv record GHSA-389g-gv7q-r4x8
- Revision 1 · created ·
Published from ghsa record GHSA-389g-gv7q-r4x8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-107832 Advisory: fastify is vulnerable to header validation bypass via case-sensitive propertyNames IDs: CVE-2026-107832, GHSA-389g-gv7q-r4x8 Record: https://patchnext.com/advisories/cve-2026-107832 (revision 3, source checked 26 Oct 2026, 13:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: fastify 5.12.6. A vendor fix does not mean a deployment is fixed. ## Affected components - npm fastify: affected >= 5.12.2, < 5.12.6; fixed in 5.12.6 ## Suggested inspection (read-only) - `npm ls fastify --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on fastify. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-389g-gv7q-r4x8 (GitHub-reviewed advisory GHSA-389g-gv7q-r4x8 lists affected ranges: npm fastify >=5.12.2 <5.12.6) - Verified: https://osv.dev/vulnerability/GHSA-389g-gv7q-r4x8 (OSV record GHSA-389g-gv7q-r4x8 lists affected ranges: npm fastify >=5.12.2 <5.12.6 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…