Skip to content

← Actionable
High, CVSS 7.5amended

Nginx UI: Unauthenticated signed-request body staging can exhaust temporary storage

CVE-2026-107805GHSA-j3hg-9rp3-5hw9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/0xJacky/Nginx-UI 1.9.10-0.20260901043436-8c9b9a1aff21), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/0xJacky/Nginx-UI

    Affected
    >= 1.9.10-0.20260729084040-acb59fdd81db, < 1.9.10-0.20260901043436-8c9b9a1aff21
    Fixed in
    1.9.10-0.20260901043436-8c9b9a1aff21

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-107805: 0.47% estimated exploitation activity in the next 30 days; percentile 40.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary In Nginx UI versions 2.5.0 through 2.5.x, the node-signature authentication path staged an attacker-controlled request body in a temporary file and synchronized it to disk before validating the body digest and cryptographic signature. An unauthenticated remote client that can reach the API can provide syntactically valid signature metadata and cause storage and I/O consumption before the request is rejected. Impact Concurrent malicious requests can consume temporary filesystem capacity, disk I/O, and request-processing resources, potentially disrupting Nginx UI and other services that share the filesystem. The issue affects availability only; it does not bypass authentication and does not provide confidentiality or integrity impact. Deployment-specific reverse-proxy body limits, filesystem quotas, and concurrency limits may reduce practical impact. Remediation Upgrade to Nginx UI 2.6.0 or later. The fix authenticates signed request metadata before staging the body and…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-j3hg-9rp3-5hw9

  2. Revision 2 · amended ·

    Amended from osv record GO-2026-6734

  3. Revision 1 · created ·

    Published from osv record GHSA-j3hg-9rp3-5hw9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-107805

Advisory: Nginx UI: Unauthenticated signed-request body staging can exhaust temporary storage
IDs: CVE-2026-107805, GHSA-j3hg-9rp3-5hw9
Record: https://patchnext.com/advisories/cve-2026-107805 (revision 3, source checked 26 Oct 2026, 15:32 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/0xJacky/Nginx-UI 1.9.10-0.20260901043436-8c9b9a1aff21. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/0xJacky/Nginx-UI: affected >= 1.9.10-0.20260729084040-acb59fdd81db, < 1.9.10-0.20260901043436-8c9b9a1aff21; fixed in 1.9.10-0.20260901043436-8c9b9a1aff21

## Suggested inspection (read-only)
- Go github.com/0xJacky/Nginx-UI: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/0xJacky/Nginx-UI.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GO-2026-6734 (OSV record GO-2026-6734 lists affected ranges: Go github.com/0xJacky/Nginx-UI >=1.9.10-0.20260729084040-acb59fdd81db <1.9.10-0.20260901043436-8c9b9a1aff21 (fixed))
- Verified: https://osv.dev/vulnerability/GHSA-j3hg-9rp3-5hw9 (OSV record GHSA-j3hg-9rp3-5hw9 lists affected ranges: Go github.com/0xJacky/Nginx-UI >=1.9.10-0.20260729084040-acb59fdd81db <1.9.10-0.20260901043436-8c9b9a1aff21 (fixed))
- Verified: https://github.com/advisories/GHSA-j3hg-9rp3-5hw9 (GitHub-reviewed advisory GHSA-j3hg-9rp3-5hw9 lists affected ranges: Go github.com/0xJacky/Nginx-UI >=1.9.10-0.20260729084040-acb59fdd81db <1.9.10-0.20260901043436-8c9b9a1aff21)

Commands are suggestions: review each one before running it.

Loading voting…