Skip to content

← Actionable
Medium, CVSS 5.3amended

Nginx UI: Bundled reverse proxy can bypass IP allowlists and enable shared login lockout

CVE-2026-107804GHSA-9h23-53f4-q947

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/0xJacky/Nginx-UI 1.9.10-0.20260904075558-e30e331303fc), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/0xJacky/Nginx-UI

    Affected
    >= 1.9.10-0.20251005005631-6de168c9454, < 1.9.10-0.20260904075558-e30e331303fc
    Fixed in
    1.9.10-0.20260904075558-e30e331303fc

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2026-107804: 0.22% estimated exploitation activity in the next 30 days; percentile 12.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary In Nginx UI versions 2.2.0 through 2.5.x, the official bundled reverse-proxy topology did not preserve the external client identity used by Gin. The backend treated the local proxy peer as the client because no trusted proxy was configured, while the proxy supplied the actual address in forwarding headers. Impact This has two distinct effects in bundled-proxy deployments: IP allowlist enforcement: management API requests forwarded by the bundled proxy were identified as loopback and could pass the loopback exception even when the external source was not in the configured allowlist. Protected management operations still required valid credentials; this did not grant unauthenticated administrator access. Login availability: failed login attempts from different external sources were attributed to one loopback address. An unauthenticated attacker could therefore trigger the shared temporary login-ban threshold and deny password or OTP login to other users behind the proxy until…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-9h23-53f4-q947

  2. Revision 2 · amended ·

    Amended from osv record GO-2026-6724

  3. Revision 1 · created ·

    Published from osv record GHSA-9h23-53f4-q947

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-107804

Advisory: Nginx UI: Bundled reverse proxy can bypass IP allowlists and enable shared login lockout
IDs: CVE-2026-107804, GHSA-9h23-53f4-q947
Record: https://patchnext.com/advisories/cve-2026-107804 (revision 3, source checked 26 Oct 2026, 15:32 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/0xJacky/Nginx-UI 1.9.10-0.20260904075558-e30e331303fc. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/0xJacky/Nginx-UI: affected >= 1.9.10-0.20251005005631-6de168c9454, < 1.9.10-0.20260904075558-e30e331303fc; fixed in 1.9.10-0.20260904075558-e30e331303fc

## Suggested inspection (read-only)
- Go github.com/0xJacky/Nginx-UI: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/0xJacky/Nginx-UI.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GO-2026-6724 (OSV record GO-2026-6724 lists affected ranges: Go github.com/0xJacky/Nginx-UI >=0 <1.9.10-0.20260904075558-e30e331303fc (fixed))
- Verified: https://osv.dev/vulnerability/GHSA-9h23-53f4-q947 (OSV record GHSA-9h23-53f4-q947 lists affected ranges: Go github.com/0xJacky/Nginx-UI >=1.9.10-0.20251005005631-6de168c9454 <1.9.10-0.20260904075558-e30e331303fc (fixed))
- Verified: https://github.com/advisories/GHSA-9h23-53f4-q947 (GitHub-reviewed advisory GHSA-9h23-53f4-q947 lists affected ranges: Go github.com/0xJacky/Nginx-UI >=1.9.10-0.20251005005631-6de168c9454 <1.9.10-0.20260904075558-e30e331303fc)

Commands are suggestions: review each one before running it.

Loading voting…