Skip to content

← Actionable
High, CVSS 7.4amended

fast-jwt treats raw public JWK JSON as an HMAC secret, enabling HS256 token forgery

CVE-2026-107724GHSA-g3jj-5cmm-3hxx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (fast-jwt 6.3.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm fast-jwt

    Affected
    >= 6.2.4, <= 6.2.4
    Fixed in
    6.3.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-107724: 0.28% estimated exploitation activity in the next 30 days; percentile 20.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary fast-jwt 6.2.4 silently classifies raw serialized public JWK JSON as an HMAC secret. If an application supplies public JWK JSON text as the verifier key and HS256 is explicitly allowed or automatically inferred, an attacker who knows the same public JSON text can use it as an HMAC key and create an arbitrary HS256 token that fast-jwt accepts as valid. This can result in authentication or authorization bypass through forged JWT claims. The PoC demonstrates the issue with a serialized RSA public JWK. The same non-PEM classification also applies to raw JWKS JSON text, although the attached standalone PoC focuses on the smallest JWK case. Details The verifier accepts a string or Buffer as key material. In src/crypto.js, performDetectPublicKeyAlgorithms() attempts to infer the permitted algorithm family from the supplied string. Strings matching supported PEM public-key formats are classified as asymmetric keys. Any other non-empty string is assumed to be an HMAC secret: js…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-g3jj-5cmm-3hxx

  2. Revision 2 · amended ·

    Amended from osv record GHSA-g3jj-5cmm-3hxx

  3. Revision 1 · created ·

    Published from ghsa record GHSA-g3jj-5cmm-3hxx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-107724

Advisory: fast-jwt treats raw public JWK JSON as an HMAC secret, enabling HS256 token forgery
IDs: CVE-2026-107724, GHSA-g3jj-5cmm-3hxx
Record: https://patchnext.com/advisories/cve-2026-107724 (revision 3, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: fast-jwt 6.3.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm fast-jwt: affected >= 6.2.4, <= 6.2.4; fixed in 6.3.0

## Suggested inspection (read-only)
- `npm ls fast-jwt --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on fast-jwt.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-g3jj-5cmm-3hxx (GitHub-reviewed advisory GHSA-g3jj-5cmm-3hxx lists affected ranges: npm fast-jwt >=6.2.4 <=6.2.4)
- Verified: https://osv.dev/vulnerability/GHSA-g3jj-5cmm-3hxx (OSV record GHSA-g3jj-5cmm-3hxx lists affected ranges: npm fast-jwt >=6.2.4 <6.3.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…