Skip to content

← Actionable
High, CVSS 8.1amended

fast-jwt : Silent claim-validator bypass when JWT payload is a JSON array

CVE-2026-107723GHSA-5hjw-83fp-phq9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (fast-jwt 6.3.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm fast-jwt

    Affected
    <= 6.2.4
    Fixed in
    6.3.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-107723: 0.46% estimated exploitation activity in the next 30 days; percentile 39.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary fast-jwt's createVerifier silently skips all configured claim validators (exp, nbf, iss, aud, sub, jti, nonce) when a validly-signed JWT carries a JSON array as its payload instead of an object. The verifier reports success while having enforced only the signature. This breaks the library's documented allowedIss / allowedAud / allowedSub / expiry / replay-protection guarantees and violates RFC 7519 §7.2 step 10, which requires the JWT Claims Set to be a JSON object. Details The decoder validates the header is a non-array object but the payload check is missing the Array.isArray guard: PoC Suggested patch (src/decoder.js:65): - if (!payload || typeof payload !== 'object') { + if (!payload || typeof payload !== 'object' || Array.isArray(payload)) { throw new TokenError(TokenError.codes.invalidPayload, 'The payload must be an object', { payload }) } This mirrors the existing header guard at line 49. Impact Type: Silent authorization-validator bypass. When a validly-signed JWT…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-5hjw-83fp-phq9

  2. Revision 2 · amended ·

    Amended from osv record GHSA-5hjw-83fp-phq9

  3. Revision 1 · created ·

    Published from ghsa record GHSA-5hjw-83fp-phq9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-107723

Advisory: fast-jwt : Silent claim-validator bypass when JWT payload is a JSON array
IDs: CVE-2026-107723, GHSA-5hjw-83fp-phq9
Record: https://patchnext.com/advisories/cve-2026-107723 (revision 3, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: fast-jwt 6.3.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm fast-jwt: affected <= 6.2.4; fixed in 6.3.0

## Suggested inspection (read-only)
- `npm ls fast-jwt --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on fast-jwt.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5hjw-83fp-phq9 (GitHub-reviewed advisory GHSA-5hjw-83fp-phq9 lists affected ranges: npm fast-jwt >=0 <=6.2.4)
- Verified: https://osv.dev/vulnerability/GHSA-5hjw-83fp-phq9 (OSV record GHSA-5hjw-83fp-phq9 lists affected ranges: npm fast-jwt >=0 <6.3.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…