fast-jwt clockTolerance: Infinity silently bypasses both exp and nbf validation (and persists in the verifier cache)
CVE-2026-107721GHSA-687g-22h4-j4w4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (fast-jwt 6.3.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm fast-jwt
- Affected
- <= 6.2.4
- Fixed in
- 6.3.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-687g-22h4-j4w4 lists affected ranges: npm fast-jwt >=0 <=6.2.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-687g-22h4-j4w4 lists affected ranges: npm fast-jwt >=0 <6.3.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-107721: 0.34% estimated exploitation activity in the next 30 days; percentile 27.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary createVerifier({ clockTolerance: Infinity }) silently bypasses both exp (expiry) AND nbf (not-before) validation. Any expired or not-yet-active token is accepted as valid. The same primitive also corrupts the verifier's internal cache so cached entries inherit infinite validity — they remain valid past a later developer-removed Infinity config until LRU eviction. Vulnerable code src/verifier.js:531-533 — option validation only rejects negative values, not Infinity: Infinity passes (it's a number, not less than 0, truthy). src/verifier.js:583-602 — clockTolerance flows into the date-claim validators: src/verifier.js:198-205 — applies modifier additively, producing always-pass comparisons: Empirical PoC Verified against fast-jwt@HEAD on 2026-06-03 (commit pulled today). Cache side-effect The verifier's LRU cache uses clockTolerance to compute the cache entry's expiry window: src/verifier.js:121-134: With clockTolerance: Infinity, cache entries are stored with min=-Infinity,…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-687g-22h4-j4w4
- Revision 2 · amended ·
Amended from osv record GHSA-687g-22h4-j4w4
- Revision 1 · created ·
Published from ghsa record GHSA-687g-22h4-j4w4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-107721 Advisory: fast-jwt clockTolerance: Infinity silently bypasses both exp and nbf validation (and persists in the verifier cache) IDs: CVE-2026-107721, GHSA-687g-22h4-j4w4 Record: https://patchnext.com/advisories/cve-2026-107721 (revision 3, source checked 26 Oct 2026, 13:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: fast-jwt 6.3.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm fast-jwt: affected <= 6.2.4; fixed in 6.3.0 ## Suggested inspection (read-only) - `npm ls fast-jwt --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on fast-jwt. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-687g-22h4-j4w4 (GitHub-reviewed advisory GHSA-687g-22h4-j4w4 lists affected ranges: npm fast-jwt >=0 <=6.2.4) - Verified: https://osv.dev/vulnerability/GHSA-687g-22h4-j4w4 (OSV record GHSA-687g-22h4-j4w4 lists affected ranges: npm fast-jwt >=0 <6.3.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…