Skip to content

← Actionable
High, CVSS 7.4amended

fast-jwt: createVerifier accepts unsigned JWTs when key is '' or null and algorithms is explicitly set

CVE-2026-107720GHSA-8wpc-h4q6-8fxv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (fast-jwt 6.3.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm fast-jwt

    Affected
    <= 6.3.0
    Fixed in
    6.3.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-107720: 0.32% estimated exploitation activity in the next 30 days; percentile 25.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary createVerifier in fast-jwt ≤ 6.3.0 skips signature verification entirely when the key option is a falsy synchronous value ('' or null) and the algorithms option is set to a non-empty allowlist. An attacker who can present a JWT to the application — regardless of algorithm — can forge arbitrary claims without possessing any signing key. Details Root cause — four cooperating code paths: A. Falsy sync keys bypass prepareKeyOrSecret createVerifier branches on typeof key: When key is '' (string, falsy) or null (object, falsy) the outer type check passes but the if (key && ...) guard never calls prepareKeyOrSecret. The empty-secret rejection added in that function is therefore never reached for sync keys: B. Explicit algorithms keeps an allowlist active with no key When key is falsy, autodetection is skipped and the caller-supplied algorithms (e.g. ['HS256']) is retained in allowedAlgorithms. The verifier therefore accepts tokens whose header matches that list. C. hasKey is false →…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-8wpc-h4q6-8fxv

  2. Revision 2 · amended ·

    Amended from osv record GHSA-8wpc-h4q6-8fxv

  3. Revision 1 · created ·

    Published from ghsa record GHSA-8wpc-h4q6-8fxv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-107720

Advisory: fast-jwt: createVerifier accepts unsigned JWTs when key is '' or null and algorithms is explicitly set
IDs: CVE-2026-107720, GHSA-8wpc-h4q6-8fxv
Record: https://patchnext.com/advisories/cve-2026-107720 (revision 3, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: fast-jwt 6.3.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm fast-jwt: affected <= 6.3.0; fixed in 6.3.1

## Suggested inspection (read-only)
- `npm ls fast-jwt --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on fast-jwt.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8wpc-h4q6-8fxv (GitHub-reviewed advisory GHSA-8wpc-h4q6-8fxv lists affected ranges: npm fast-jwt >=0 <=6.3.0)
- Verified: https://osv.dev/vulnerability/GHSA-8wpc-h4q6-8fxv (OSV record GHSA-8wpc-h4q6-8fxv lists affected ranges: npm fast-jwt >=0 <6.3.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…