Skip to content

← Actionable
Medium, CVSS 4.2amended

fast-jwt: Verifier cache accepts expired JWTs without iat.

CVE-2026-107719GHSA-x937-hj6v-793p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (fast-jwt 6.3.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm fast-jwt

    Affected
    <= 6.3.3
    Fixed in
    6.3.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.2 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2026-107719: 0.27% estimated exploitation activity in the next 30 days; percentile 19.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary cacheSet only derives its exp cache deadline inside hasIat (src/verifier.js:127-140). JWT iat is optional. For a valid token with exp but no iat, cacheSet substitutes clockTimestamp + clockTolerance + cacheTTL (src/verifier.js:142-146). Later, the cache path returns the saved payload before decoding or invoking verifyToken (src/verifier.js:372-388). Since expiration validation is in verifyToken, the expired token remains accepted until the cache deadline. Details The bug is an expiration-check bypass caused by caching. Normally, verification works like this: 1. Verify signature. 2. Check exp against the current time. 3. Return the JWT claims. With caching enabled, fast-jwt saves successful verification results so it can avoid repeating crypto work for the same token. The intended invariant is: A cached token must stop being accepted at the same time as a non-cached token. But the cache computes its expiration incorrectly. In fast-jwt/src/verifier.js:127, the code first checks…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-x937-hj6v-793p

  2. Revision 2 · amended ·

    Amended from osv record GHSA-x937-hj6v-793p

  3. Revision 1 · created ·

    Published from ghsa record GHSA-x937-hj6v-793p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-107719

Advisory: fast-jwt: Verifier cache accepts expired JWTs without iat.
IDs: CVE-2026-107719, GHSA-x937-hj6v-793p
Record: https://patchnext.com/advisories/cve-2026-107719 (revision 3, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: fast-jwt 6.3.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm fast-jwt: affected <= 6.3.3; fixed in 6.3.4

## Suggested inspection (read-only)
- `npm ls fast-jwt --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on fast-jwt.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-x937-hj6v-793p (GitHub-reviewed advisory GHSA-x937-hj6v-793p lists affected ranges: npm fast-jwt >=0 <=6.3.3)
- Verified: https://osv.dev/vulnerability/GHSA-x937-hj6v-793p (OSV record GHSA-x937-hj6v-793p lists affected ranges: npm fast-jwt >=0 <6.3.4 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…