Skip to content

← Actionable
Unratedamended

Banks: Symlink traversal and arbitrary file disclosure/overwrite in DirectoryPromptRegistry

CVE-2026-107716GHSA-556j-vv39-8rqv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (banks 2.5.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI banks

    Affected
    <= 2.5.0
    Fixed in
    2.5.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2026-107716: 0.13% estimated exploitation activity in the next 30 days; percentile 2.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary In banks.registries.DirectoryPromptRegistry, prompt file paths and the index file (index.json) do not refuse symbolic links. When a prompt directory contains or accepts untrusted files (e.g. unpacked archives, shared repositories, or multi-tenant folders), symbolic links pointing outside the registry root can be used to disclose arbitrary files via scan() / get() or overwrite arbitrary files via set() / save(). Details Following PR #77, DirectoryPromptRegistry validates path resolution for prompt names. However: 1. self.indexpath (index.json) is not checked for symbolic links. A symlink pointing to an external target (e.g. a configuration file) will be overwritten by save() upon reg.set(), or read via load(). 2. In scan(), discovered .jinja files are opened and indexed without checking if path.issymlink() or if the resolved path escapes the registry root. A symlink pointing to a sensitive file outside the root is read and indexed. 3. In set(), promptfile.writetext(...) is…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-556j-vv39-8rqv

  2. Revision 2 · amended ·

    Amended from osv record GHSA-556j-vv39-8rqv

  3. Revision 1 · created ·

    Published from ghsa record GHSA-556j-vv39-8rqv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-107716

Advisory: Banks: Symlink traversal and arbitrary file disclosure/overwrite in DirectoryPromptRegistry
IDs: CVE-2026-107716, GHSA-556j-vv39-8rqv
Record: https://patchnext.com/advisories/cve-2026-107716 (revision 3, source checked 26 Oct 2026, 13:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: banks 2.5.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI banks: affected <= 2.5.0; fixed in 2.5.1

## Suggested inspection (read-only)
- `python -m pip show banks`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on banks.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-556j-vv39-8rqv (GitHub-reviewed advisory GHSA-556j-vv39-8rqv lists affected ranges: PyPI banks >=0 <=2.5.0)
- Verified: https://osv.dev/vulnerability/GHSA-556j-vv39-8rqv (OSV record GHSA-556j-vv39-8rqv lists affected ranges: PyPI banks >=0 <2.5.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…