Skip to content

← Actionable
Medium, CVSS 6.8amended

Mechanize sends credential headers to another host after an HTTP redirect

CVE-2026-107715GHSA-2mwr-xjcg-37j7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mechanize 2.14.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems mechanize

    Affected
    < 2.14.1
    Fixed in
    2.14.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:N/A:N
EPSS
  • CVE-2026-107715: 0.50% estimated exploitation activity in the next 30 days; percentile 42.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary mechanize leaked credentials to the redirect target when an HTTP redirect crossed to another host. Credentials set through Mechanize#requestheaders= leaked even when they were Authorization. Details Two defects, both in lib/mechanize/http/agent.rb. 1. Mechanize#requestheaders= bypassed the redirect strip entirely. #requestaddheaders copied @requestheaders onto every request unconditionally, with no host check, including the request issued after a redirect. The strip in #responseredirect mutated only the per-request headers hash and never touched agent state. Because requestheaders= is the documented way to set a default credential for every request, the header the code explicitly protected — Authorization — was the one most likely to leak. 2. The strip list omitted Proxy-Authorization and Cookie2. Only CREDENTIALHEADERS = ['Authorization'] and COOKIEHEADERS = ['Cookie'] were removed from the per-request headers hash on a cross-host redirect. Cookies held in…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-2mwr-xjcg-37j7

  2. Revision 1 · created ·

    Published from osv record GHSA-2mwr-xjcg-37j7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-107715

Advisory: Mechanize sends credential headers to another host after an HTTP redirect
IDs: CVE-2026-107715, GHSA-2mwr-xjcg-37j7
Record: https://patchnext.com/advisories/cve-2026-107715 (revision 2, source checked 26 Oct 2026, 15:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mechanize 2.14.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems mechanize: affected < 2.14.1; fixed in 2.14.1

## Suggested inspection (read-only)
- RubyGems mechanize: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mechanize.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2mwr-xjcg-37j7 (OSV record GHSA-2mwr-xjcg-37j7 lists affected ranges: RubyGems mechanize >=0 <2.14.1 (fixed))
- Verified: https://github.com/advisories/GHSA-2mwr-xjcg-37j7 (GitHub-reviewed advisory GHSA-2mwr-xjcg-37j7 lists affected ranges: RubyGems mechanize >=0 <2.14.1)

Commands are suggestions: review each one before running it.

Loading voting…