s2n-quic has excessive memory allocation
CVE-2026-10740GHSA-9q54-f358-3fqf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (s2n-quic 1.82.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io s2n-quic
- Affected
- <= 1.81.0
- Fixed in
- 1.82.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9q54-f358-3fqf lists affected ranges: crates.io s2n-quic >=0 <1.82.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9q54-f358-3fqf lists affected ranges: crates.io s2n-quic >=0 <=1.81.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-10740: 0.29% estimated exploitation activity in the next 30 days; percentile 21.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
s2n-quic is a Rust implementation of the QUIC protocol. An unauthenticated user can attempt to exhaust server memory on an s2n-quic endpoint by sending crafted CRYPTO frames with high offsets. The buffer used for processing CRYPTO frames does not enforce a maximum size. In the worst case, a single 1200-byte packet can cause approximately 9.4 MB of allocation. By repeatedly sending such packets, the resulting memory pressure could cause denial of service. No valid handshake is required. Impacted versions: <= v1.81.0 Patches This issue has been addressed in s2n-quic version v1.82.0. We recommend upgrading to the latest version and ensuring any forked or derivative code is patched to incorporate the new fixes. Workarounds There is no workaround that fully mitigates this issue. Upgrading to the patched version is the recommended remediation. References If there are any questions or comments about this advisory, contact AWS Security via the vulnerability reporting page or directly via…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-9q54-f358-3fqf
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-9q54-f358-3fqf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-10740 Advisory: s2n-quic has excessive memory allocation IDs: CVE-2026-10740, GHSA-9q54-f358-3fqf Record: https://patchnext.com/advisories/cve-2026-10740 (revision 3, source checked 26 Oct 2026, 15:43 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: s2n-quic 1.82.0. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io s2n-quic: affected <= 1.81.0; fixed in 1.82.0 ## Suggested inspection (read-only) - crates.io s2n-quic: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on s2n-quic. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9q54-f358-3fqf (OSV record GHSA-9q54-f358-3fqf lists affected ranges: crates.io s2n-quic >=0 <1.82.0 (fixed)) - Verified: https://github.com/advisories/GHSA-9q54-f358-3fqf (GitHub-reviewed advisory GHSA-9q54-f358-3fqf lists affected ranges: crates.io s2n-quic >=0 <=1.81.0) Commands are suggestions: review each one before running it.
Loading voting…