Skip to content

← Actionable
Medium, CVSS 6.3amended

amqp091-go: Pre-negotiation frame limit is not enforced to 4KB

CVE-2026-107386GHSA-w6r9-248c-frg8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/rabbitmq/amqp091-go 1.14.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-107386: 0.49% estimated exploitation activity in the next 30 days; percentile 42.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The frame-size mitigation released in amqp091-go v1.13.0 can be bypassed before connection.tune completes. A malicious or compromised AMQP peer can send only a seven-byte body-frame header containing a large attacker-controlled uint32 payload length. The client allocates a slice of that declared length before it verifies that the payload exists or rejects the frame for its invalid protocol state. The bypass occurs because Connection.maxFrameSize starts at zero. The reader interprets zero as both “negotiated unlimited” and “not negotiated yet,” and skips the pre-allocation size check in either case. Open starts the reader goroutine before negotiation and does not store a limit until after it receives connection.tune. This remains reachable even if the caller explicitly uses Config{FrameSize: frameMinSize}. A malicious broker can therefore cause excessive memory allocation, potentially terminating the Go client process through memory exhaustion, before authentication and…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-w6r9-248c-frg8

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GO-2026-6700

  4. Revision 1 · created ·

    Published from osv record GHSA-w6r9-248c-frg8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-107386

Advisory: amqp091-go: Pre-negotiation frame limit is not enforced to 4KB
IDs: CVE-2026-107386, GHSA-w6r9-248c-frg8
Record: https://patchnext.com/advisories/cve-2026-107386 (revision 4, source checked 26 Oct 2026, 15:32 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/rabbitmq/amqp091-go 1.14.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/rabbitmq/amqp091-go: affected < 1.14.0; fixed in 1.14.0

## Suggested inspection (read-only)
- Go github.com/rabbitmq/amqp091-go: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/rabbitmq/amqp091-go.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GO-2026-6700 (OSV record GO-2026-6700 lists affected ranges: Go github.com/rabbitmq/amqp091-go >=0 <1.14.0 (fixed))
- Verified: https://osv.dev/vulnerability/GHSA-w6r9-248c-frg8 (OSV record GHSA-w6r9-248c-frg8 lists affected ranges: Go github.com/rabbitmq/amqp091-go >=0 <1.14.0 (fixed))
- Verified: https://github.com/advisories/GHSA-w6r9-248c-frg8 (GitHub-reviewed advisory GHSA-w6r9-248c-frg8 lists affected ranges: Go github.com/rabbitmq/amqp091-go >=0 <1.14.0)

Commands are suggestions: review each one before running it.

Loading voting…