Skip to content

← Actionable
High, CVSS 7.4amended

MariaDB Connector/Node.js: SQL injection in the text protocol when the session uses NO_BACKSLASH_ESCAPES

CVE-2026-107385GHSA-r3rv-jm3r-62q2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mariadb 3.5.4, 3.4.7, 3.3.4, 3.2.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm mariadb

    Affected
    < 3.2.5>= 3.3.0, < 3.3.4>= 3.4.0, < 3.4.7>= 3.5.0-rc.0, < 3.5.4
    Fixed in
    3.4.7, 3.5.4, 3.2.5, 3.3.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:H
EPSS
  • CVE-2026-107385: 0.44% estimated exploitation activity in the next 30 days; percentile 38.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description When escaping string and binary parameters for the text protocol, the connector always escaped the quote character with a backslash, without ever consulting the session's NOBACKSLASHESCAPES SQL mode. The server status flag was declared (STATUSNOBACKSLASHESCAPES) but never read. Under a server or session running with NOBACKSLASHESCAPES, the backslash is an ordinary character and the quote must be escaped by doubling it. The escaped value produced by the connector therefore closed the string literal, and a value passed through a placeholder was interpreted as SQL. All text-protocol escaping entry points were affected, including Connection.escape(). Impact An attacker able to influence any value the application passes as a query parameter could execute arbitrary SQL with the privileges of the application's database user: read, modify or delete any data reachable by that connection. Exposure requires a deployment where NOBACKSLASHESCAPES is enabled — server-wide, through the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-r3rv-jm3r-62q2

  2. Revision 2 · amended ·

    Amended from osv record GHSA-r3rv-jm3r-62q2

  3. Revision 1 · created ·

    Published from ghsa record GHSA-r3rv-jm3r-62q2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-107385

Advisory: MariaDB Connector/Node.js: SQL injection in the text protocol when the session uses NO_BACKSLASH_ESCAPES
IDs: CVE-2026-107385, GHSA-r3rv-jm3r-62q2
Record: https://patchnext.com/advisories/cve-2026-107385 (revision 3, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mariadb 3.5.4, 3.4.7, 3.3.4, 3.2.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm mariadb: affected < 3.2.5; >= 3.3.0, < 3.3.4; >= 3.4.0, < 3.4.7; >= 3.5.0-rc.0, < 3.5.4; fixed in 3.4.7, 3.5.4, 3.2.5, 3.3.4

## Suggested inspection (read-only)
- `npm ls mariadb --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mariadb.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-r3rv-jm3r-62q2 (GitHub-reviewed advisory GHSA-r3rv-jm3r-62q2 lists affected ranges: npm mariadb >=0 =3.3.0 =3.4.0 =3.5.0-rc.0 <3.5.4)
- Verified: https://osv.dev/vulnerability/GHSA-r3rv-jm3r-62q2 (OSV record GHSA-r3rv-jm3r-62q2 lists affected ranges: npm mariadb >=0 =3.3.0 =3.4.0 =3.5.0-rc.0 <3.5.4 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…