MariaDB Connector/Node.js: SQL injection through object keys in SET expansion (permitSetMultiParamEntries)
CVE-2026-107384GHSA-v6pj-gxxw-phfw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mariadb 3.5.4, 3.4.7, 3.3.4, 3.2.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm mariadb
- Affected
- >= 3.2.0, < 3.2.5>= 3.3.0, < 3.3.4>= 3.4.0, < 3.4.7>= 3.5.0-rc.0, < 3.5.4
- Fixed in
- 3.4.7, 3.5.4, 3.2.5, 3.3.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v6pj-gxxw-phfw lists affected ranges: npm mariadb >=3.2.0 =3.3.0 =3.4.0 =3.5.0-rc.0 <3.5.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-v6pj-gxxw-phfw lists affected ranges: npm mariadb >=3.2.0 =3.3.0 =3.4.0 =3.5.0-rc.0 <3.5.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-107384: 0.45% estimated exploitation activity in the next 30 days; percentile 38.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description With the non-default permitSetMultiParamEntries option enabled, an object passed as a query parameter is expanded into a SET clause, each key becoming a column name. The three code paths implementing that expansion built the backtick-quoted identifier by hand and wrote the key out unescaped, while only the value was escaped. A key containing a backtick therefore closed the identifier, and the remainder of the key was parsed as SQL. The connector's own identifier escaper (escapeId, which correctly doubles backticks) existed but was not called from any of the three sites. This is an incomplete fix of GitHub issue #252, which corrected escapeId itself in 2023 but left these hand-built call sites unchanged. Impact An application that enables permitSetMultiParamEntries and passes an object with attacker-influenced keys into a statement such as conn.query('UPDATE users SET ? WHERE id = ?', [body, id]) allows the caller to write columns the application never intended to expose —…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-v6pj-gxxw-phfw
- Revision 2 · amended ·
Amended from osv record GHSA-v6pj-gxxw-phfw
- Revision 1 · created ·
Published from ghsa record GHSA-v6pj-gxxw-phfw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-107384 Advisory: MariaDB Connector/Node.js: SQL injection through object keys in SET expansion (permitSetMultiParamEntries) IDs: CVE-2026-107384, GHSA-v6pj-gxxw-phfw Record: https://patchnext.com/advisories/cve-2026-107384 (revision 3, source checked 26 Oct 2026, 13:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mariadb 3.5.4, 3.4.7, 3.3.4, 3.2.5. A vendor fix does not mean a deployment is fixed. ## Affected components - npm mariadb: affected >= 3.2.0, < 3.2.5; >= 3.3.0, < 3.3.4; >= 3.4.0, < 3.4.7; >= 3.5.0-rc.0, < 3.5.4; fixed in 3.4.7, 3.5.4, 3.2.5, 3.3.4 ## Suggested inspection (read-only) - `npm ls mariadb --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mariadb. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-v6pj-gxxw-phfw (GitHub-reviewed advisory GHSA-v6pj-gxxw-phfw lists affected ranges: npm mariadb >=3.2.0 =3.3.0 =3.4.0 =3.5.0-rc.0 <3.5.4) - Verified: https://osv.dev/vulnerability/GHSA-v6pj-gxxw-phfw (OSV record GHSA-v6pj-gxxw-phfw lists affected ranges: npm mariadb >=3.2.0 =3.3.0 =3.4.0 =3.5.0-rc.0 <3.5.4 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…