Skip to content

← Actionable
Medium, CVSS 5.9amended

MariaDB Connector/Node.js: Uncaught exception crashes the client during ed25519 authentication with zero-configuration TLS

CVE-2026-107382GHSA-cx2f-j9fh-8g68

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mariadb 3.5.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm mariadb

    Affected
    >= 3.3.0, < 3.5.4
    Fixed in
    3.5.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-107382: 0.24% estimated exploitation activity in the next 30 days; percentile 14.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description On the zero-configuration TLS path, the connector accepts a self-signed server certificate at the TLS level and then validates the server's identity from the fingerprint hash the server appends to the final OKPacket (Authentication.validateFingerPrint). That validation calls hash() on the authentication plugin in use to obtain the password-derived secret both sides combine with the seed and the certificate fingerprint. Ed25519PasswordAuth.hash() referenced an identifier seed that was not in scope: it was neither a parameter of the method nor a module-scope binding, existing only as a parameter of the unrelated static encryptPassword(password, seed). Invoking the method therefore threw ReferenceError: seed is not defined. The throw happens synchronously inside the socket data handler, and no frame between PacketInputStream.onData() and the plugin guards it, so the error escapes as an uncaught exception rather than surfacing as a connection error. Because the fingerprint…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-cx2f-j9fh-8g68

  2. Revision 2 · amended ·

    Amended from osv record GHSA-cx2f-j9fh-8g68

  3. Revision 1 · created ·

    Published from ghsa record GHSA-cx2f-j9fh-8g68

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-107382

Advisory: MariaDB Connector/Node.js: Uncaught exception crashes the client during ed25519 authentication with zero-configuration TLS
IDs: CVE-2026-107382, GHSA-cx2f-j9fh-8g68
Record: https://patchnext.com/advisories/cve-2026-107382 (revision 3, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mariadb 3.5.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm mariadb: affected >= 3.3.0, < 3.5.4; fixed in 3.5.4

## Suggested inspection (read-only)
- `npm ls mariadb --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mariadb.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-cx2f-j9fh-8g68 (GitHub-reviewed advisory GHSA-cx2f-j9fh-8g68 lists affected ranges: npm mariadb >=3.3.0 <3.5.4)
- Verified: https://osv.dev/vulnerability/GHSA-cx2f-j9fh-8g68 (OSV record GHSA-cx2f-j9fh-8g68 lists affected ranges: npm mariadb >=3.3.0 <3.5.4 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…