Skip to content

← Actionable
High, CVSS 7.5amended

datamodel-code-generator: Protobuf weak-import path traversal allows files to be written outside the temporary directory

CVE-2026-107377GHSA-77xj-x4rm-935c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (datamodel-code-generator 0.81.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2026-107377: 0.53% estimated exploitation activity in the next 30 days; percentile 45.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary When processing an attacker-controlled Protobuf schema, vulnerable versions of datamodel-code-generator could write a generated weak-import stub outside the intended weakimports temporary directory. Absolute import paths and relative paths containing .. could escape this directory. An attacker could create directories and new files at locations writable by the process. Relative path traversal could also overwrite existing writable files because the existence check and the stub write used different base directories. An existing absolute target was skipped by the existence check. Written content was limited to a generated Protobuf syntax declaration, syntax = "proto2"; or syntax = "proto3";, followed by a newline. This issue did not provide fully attacker-controlled file contents, and direct arbitrary code execution has not been demonstrated. These filesystem side effects occurred before protoc ran. A subsequent compilation error did not undo them. A user or CI job must process…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-77xj-x4rm-935c

  2. Revision 2 · amended ·

    Amended from osv record GHSA-77xj-x4rm-935c

  3. Revision 1 · created ·

    Published from ghsa record GHSA-77xj-x4rm-935c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-107377

Advisory: datamodel-code-generator: Protobuf weak-import path traversal allows files to be written outside the temporary directory
IDs: CVE-2026-107377, GHSA-77xj-x4rm-935c
Record: https://patchnext.com/advisories/cve-2026-107377 (revision 3, source checked 26 Oct 2026, 13:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: datamodel-code-generator 0.81.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI datamodel-code-generator: affected >= 0.59.0, <= 0.80.0; fixed in 0.81.0

## Suggested inspection (read-only)
- `python -m pip show datamodel-code-generator`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on datamodel-code-generator.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-77xj-x4rm-935c (GitHub-reviewed advisory GHSA-77xj-x4rm-935c lists affected ranges: PyPI datamodel-code-generator >=0.59.0 <=0.80.0)
- Verified: https://osv.dev/vulnerability/GHSA-77xj-x4rm-935c (OSV record GHSA-77xj-x4rm-935c lists affected ranges: PyPI datamodel-code-generator >=0.59.0 <0.81.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…