JHipster: Generated Applications Allow Stored XSS via Unrestricted Blob ContentType Opened as Same-Origin Blob
CVE-2026-107303GHSA-9ffp-22j7-56r2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (generator-jhipster 9.4.0; react-jhipster 1.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 9.4.0
- Fixed in
- 9.4.0
npm react-jhipster
- Affected
- <= 1.0.3
- Fixed in
- 1.1.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9ffp-22j7-56r2 lists affected ranges: npm generator-jhipster >=0 =0 <=1.0.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9ffp-22j7-56r2 lists affected ranges: npm generator-jhipster >=0 =0 <1.1.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.6 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:N
- EPSS
- CVE-2026-107303: 0.32% estimated exploitation activity in the next 30 days; percentile 25.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Applications generated by generator-jhipster v9.2.0 can persist user-controlled Blob ContentType values and later use those values as the MIME type for client-side Blob objects. The shared generated openFile helper creates an object URL from the Blob and opens it in a new window. For Blob-bearing entities writable by normal authenticated users, this creates a stored XSS chain: attacker-controlled Blob content and MIME type are stored through the generated REST API, returned to privileged users, and opened as a same-origin Blob document from the generated Angular/React/Vue UI. Exploitability should be confirmed against the generated app’s CSP and target browsers. Details The root cause is a trust-boundary failure across generated server and client code. The generated entity REST resource accepts request bodies for entity creation and update. Unless an entity-specific authority is configured, the template omits method-level @PreAuthorize, leaving the endpoint available to any…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-9ffp-22j7-56r2
- Revision 2 · amended ·
Amended from osv record GHSA-9ffp-22j7-56r2
- Revision 1 · created ·
Published from ghsa record GHSA-9ffp-22j7-56r2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-107303 Advisory: JHipster: Generated Applications Allow Stored XSS via Unrestricted Blob ContentType Opened as Same-Origin Blob IDs: CVE-2026-107303, GHSA-9ffp-22j7-56r2 Record: https://patchnext.com/advisories/cve-2026-107303 (revision 3, source checked 26 Oct 2026, 13:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: generator-jhipster 9.4.0; react-jhipster 1.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm generator-jhipster: affected < 9.4.0; fixed in 9.4.0 - npm react-jhipster: affected <= 1.0.3; fixed in 1.1.0 ## Suggested inspection (read-only) - `npm ls generator-jhipster --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls react-jhipster --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on generator-jhipster, react-jhipster. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9ffp-22j7-56r2 (GitHub-reviewed advisory GHSA-9ffp-22j7-56r2 lists affected ranges: npm generator-jhipster >=0 =0 <=1.0.3) - Verified: https://osv.dev/vulnerability/GHSA-9ffp-22j7-56r2 (OSV record GHSA-9ffp-22j7-56r2 lists affected ranges: npm generator-jhipster >=0 =0 <1.1.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…