Skip to content

← Actionable
Medium, CVSS 5.3amended

msgpack5: Deeply nested input can exhaust the decoder stack

CVE-2026-107298GHSA-24ch-f2g6-9hhh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (msgpack5 6.1.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm msgpack5

    Affected
    < 6.1.0
    Fixed in
    6.1.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2026-107298: 0.37% estimated exploitation activity in the next 30 days; percentile 31.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The decoder has no nesting-depth limit for arrays and maps. An attacker who can provide MessagePack input can use deeply nested containers to exhaust the JavaScript call stack and interrupt the process or request handler. Patches The decoder now limits nesting depth to 100 by default and throws Maximum decode depth exceeded. Applications can configure the limit with the maxDepth option. Workarounds Reject deeply nested input before decoding, isolate decoding in a worker, or enforce a trusted schema with a bounded nesting depth.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-24ch-f2g6-9hhh

  2. Revision 2 · amended ·

    Amended from osv record GHSA-24ch-f2g6-9hhh

  3. Revision 1 · created ·

    Published from ghsa record GHSA-24ch-f2g6-9hhh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-107298

Advisory: msgpack5: Deeply nested input can exhaust the decoder stack
IDs: CVE-2026-107298, GHSA-24ch-f2g6-9hhh
Record: https://patchnext.com/advisories/cve-2026-107298 (revision 3, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: msgpack5 6.1.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm msgpack5: affected < 6.1.0; fixed in 6.1.0

## Suggested inspection (read-only)
- `npm ls msgpack5 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on msgpack5.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-24ch-f2g6-9hhh (GitHub-reviewed advisory GHSA-24ch-f2g6-9hhh lists affected ranges: npm msgpack5 >=0 <6.1.0)
- Verified: https://osv.dev/vulnerability/GHSA-24ch-f2g6-9hhh (OSV record GHSA-24ch-f2g6-9hhh lists affected ranges: npm msgpack5 >=0 <6.1.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…